0

I'm trying to get a livestream with the official raspicam (with IR; revision 1.3) working, which is attached on my Raspberry Pi 1 Model B+.

The problem is, that I get an gray screen when I'm accessing the camera-stream via webbrowser and it gives me the following error message: UNABLE TO OPEN VIDEO DEVICE ---- ERROR CAPTURING FIRST IMAGE

My webbrowser shows the following: enter image description here

Here is what I already tried:

  • I already installed motion and configured it like in some tutorials. The configuration file is here: http://txt.do/dzget
  • When I run raspistill -v it does display a live image on my screen, so the camera itself works.
  • I also did the command (and put it into autostart): sudo modprobe bcm2835-v4l2
  • There is also an terminal named /dev/video0.
  • I already uninstalled fswebcam and ffmpeg as suggested by some forum posts.
  • The GPU has 256 MB memory.
  • The folder which should contain the motion images is /srv/motion, but it is empty. The permissions are: pi@raspberrypi:~ $ ls -l /srv drwxr-xr-x 2 motion motion 4096 Jul 7 13:44 motion

When I view the output of the motion service, there is nothing / it does nothing:

    pi@raspberrypi:~ $ sudo motion -n -c /etc/motion/motion.conf
[0:motion] [NTC] [ALL] conf_load: Processing thread 0 - config file /etc/motion/motion.conf
[0:motion] [NTC] [ALL] motion_startup: Motion 4.0 Started
[0:motion] [NTC] [ALL] motion_startup: Logging to file (/var/log/motion/motion.log)

Could it be possible, that Raspian Stretch isn't compatible with this old camera or Raspberry?Does anyone of you know a solution to my problem?

Thank you for any help!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.