2

After opening .config/lxsession/LXDE-pi/autostart it approximately looked like this

@lxpanel --profile LXDE-pi @pcmanfm --desktop --profile LXDE-pi 
@xscreensaver -no-splash @point-rpi @lxterminal -e python3 /home/pi/Workspace/MTCNN_Tensorflow/Bildaufnahme_tensorflow

I made some line breaks so it looks like this:

@lxpanel --profile LXDE-pi 
@pcmanfm --desktop --profile LXDE-pi 
@xscreensaver -no-splash 
@point-rpi 
@lxterminal -e python3 /home/pi/Workspace/MTCNN_Tensorflow/Bildaufnahme_tensorflow

But after reboot my desktop is gone and I only got a black screen with a mouse cursor. How can I reset the .config/lxsession/LXDE-pi/autostart file so I get my old desktop back?

2

If you had SSH, you could go back and rewrite it back to the original.

If you can access your files, back them up on a USB, and reinstall your version of Raspbian.

I would like it for you to provide picture so I can give more to this answer.

  • Luckily I could still access to my files and I've backed them up. I will reinstall my Raspbian. Thank you. – Ramón Wilhelm Jul 12 '18 at 8:07
1

I haven't used LXDE so far but from a graphical user interface usually you can get to a text console by pressing {ctrl}{alt}F1 (..F2-F6). When you can switch to it then login and repair the settings. You can go back to the GUI with {alt}F7 but in your case there is only a black screen with blinking cursor so you should reboot.

  • I didn't know this comments. I will keep them in mind. Thank you. – Ramón Wilhelm Jul 12 '18 at 8:08
  • @RamónWilhelm Only to have it in mind for me: does it also work on LXDE? – Ingo Jul 12 '18 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.