1

I have nginx as a web server on my LAN.

I can access my website hosted from inside the LAN. Not OUTSIDE.

I have a static ip, and use my BEETEL 450TC1 router to port forward HTTP requests to my local static ip, using dnsdynamic services.

I get a BEETEL headed page, saying "ADSL is up, please close the browser and try again" when I open my dnsd.me domain.

I had earlier been able to do the same without any problem. Then I reset the setup and started again. This problem occurred this time.

  • Forwarding port 80 could be problematic. But are you testing the port forwarding from outside the network, or are you testing locally. Some routers don't do port forwarding if the source ip is from inside the network. – Gerben Jul 29 '13 at 10:53
3

Clearly, your BEETEL 450TC1 router does not forward the port 80 from outside to your Pi installation. You should check your router setup and make sure 1) the forwarding is enabled and 2) it forwards to the correct destination.

1

It sounds as though your router is running a service on the same (external) port that you want to use with nginx. You can test this by port forwarding from a different external port to your nginx server and see if that helps. Otherwise, look for the service within the router settings and disable it. The last thing to try is changing the port that nginx serves on and creating a new port forward to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.