I was near the end of the process of upgrading my pi from Wheezy to Stretch (which worked according to
cat /etc/os-release, I was trying to clean out old packages after reboot).
The following packages have unmet dependencies: libc-dev-bin : Depends: libc6 (< 2.14) but 2.24-11+deb9u3 is installed libc6-dev : Depends: libc6 (= 2.13-38+rpi2+deb7u8) but 2.24-11+deb9u3 is installed libnih1 : Depends: libc6 (< 2.14) but 2.24-11+deb9u3 is installed
sudo apt-get -f install to no avail. It looks like downgrading to 2.13-38+rpi2+deb7u8 would satisfy all three of the dependencies causing problems. So I tried
sudo apt-get install libc6=2.13-38+rpi2+deb7u8 but the outcome was
E: Version '2.13-38+rpi2+deb7u8' for 'libc6' was not found`
Not sure where to go from here; how to find that version of libc6 or resolve the dependency another way.