1

I was near the end of the process of upgrading my pi from Wheezy to Stretch (which worked according to cat /etc/os-release, I was trying to clean out old packages after reboot).

The following packages have unmet dependencies: libc-dev-bin : Depends: libc6 (< 2.14) but 2.24-11+deb9u3 is installed libc6-dev : Depends: libc6 (= 2.13-38+rpi2+deb7u8) but 2.24-11+deb9u3 is installed libnih1 : Depends: libc6 (< 2.14) but 2.24-11+deb9u3 is installed

I tried sudo apt-get -f install to no avail. It looks like downgrading to 2.13-38+rpi2+deb7u8 would satisfy all three of the dependencies causing problems. So I tried sudo apt-get install libc6=2.13-38+rpi2+deb7u8 but the outcome was

E: Version '2.13-38+rpi2+deb7u8' for 'libc6' was not found`

Not sure where to go from here; how to find that version of libc6 or resolve the dependency another way.

  • How do you try to clean out old packages? Do you use a specific procedure? – Ingo Jul 14 '18 at 17:12
  • @ingo I was doing sudo apt-get autoremove -y. Next was going to be sudo apt-get autoclean. – Clay Jul 14 '18 at 18:25
0

There is no official upgrade from Wheezy to Jessie - the underlying OS changes are massive from SysV to systemd!

There is also no official upgrade from Jessie to Stretch, although there were some unofficial instructions for expert users.

Do a fresh install, like practically everyone else - it will be easier in the long run.

1

Skipping an entire version was probably not a good idea; you should have upgraded to Jessie, made sure everything was more or less ok, then upgraded to Stretch.

If this is your only problem, though, it is not on the surface a big deal; libc-dev-bin is just a small collection of profiling and other development tools -- although the GCC compilers depend on it, none of this is necessary for the system to run so you should be able to uninstall it (I'm presuming it is actually installed but won't work because of the unmet dependencies):

sudo apt remove libc-gen-bin

Then try and re-install e.g., sudo apt install build-essential which will include that in hopefully the correct version for the new system.

  • I did that: > ~ $ sudo apt remove libc-gen-bin > sudo: apt: command not found So then I tried: > ~ $ sudo apt-get remove libc-gen-bin > Reading package lists... Done > Building dependency tree > Reading state information... Done > E: Unable to locate package libc-gen-bin – Clay Jul 14 '18 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.