0

MY PROBLEM:

My RasPi Zero W is causing random screen flashes.

SOME BACKGROUND:

I have three RasPi Zero W's running Jessie Lite, that I use for displaying and syncing SD video on multiple Dell UltraSharp 1708FP (17-inch) monitors. The connection is via an HDMI-to-DVI adapter. The monitor resolution is 1280 x 1024 at 75 Hz.

After days of researching a good video player that can be controlled with OSC, and even more days configuring the Pi to get it to work properly, I finally was able to play videos and control the video player remotely with OSC. All was good!

But then, while a video was playing, I lost the WIFI connection and had to reboot. After the reboot the RasPi Zero W at first displayed nothing on the attached monitor. Then the random screen flashes started. There was no RasPi console visible during the flashes. Only the Dell monitor's floating overlay, that indicates the digital input is being used, was visible at times during the random flashing.

However, I can SSH into the RasPi with no problems. So at first I thought the HDMI port or the GPU failed.

WHAT I HAVE TRIED SO FAR:

So here's what I have tried so far to debug/resolve the problem ...

I connected the problem RasPi to an HDMI monitor to confirm the RasPi was fully functional. It works fine with no display issues.

I connected the problem RasPi to a different monitor, a Dell UltraSharp 2009W (1680 x 1050 at 60 Hz), using the same HDMI-to-DVI adapter connection. After messing around with the /boot/config.txt HDMI settings, I got output on the Dell 2009W, but the console text was huge.

Then I spent days reading many posts regarding this problem and messing with every /boot/config.txt HDMI setting combination I could think of, including setting the hdmi_group=2 and the hdmi_mode=36 (which for the 1280 x 1024 at 75Hz resolution). Still no luck getting display output on the Dell 1708FP.

I flashed another SD card with a fresh Raspbian image (Stretch Lite). I used that image in a different RasPi Zero W and connected it to the monitor in question (the the Dell 1708FP). It worked great. So I can confirm the monitor works.

I have 14 Dell 1708FP monitors, so I tested the problem RasPi on a few of them, and the results were all the same ... random flashing.

I used the newly flashed SD card in the problem RasPi. The result was a black screen, no flashing.

I attach the problem RasPi with the newly flashed SD card to a different monitor, the Dell UltraSharp 2009W (1680 x 1050 at 60 Hz), using the same HDMI-to-DVI adapter connection. It works!

I tried a different HDMI-to-DVI adapter with the problem RasPi, still no luck.

This is so weird and I'm so confused!

A different RasPi with a new SD card (Stretch Lite) works on my Dell 1708FP.

The problem RasPi with the new SD card (Stretch Lite) DOES NOT work on my Dell 1708FP.

The problem RasPi with the new SD card (Stretch Lite) works on an HDMI monitor and my Dell 2009W DVI monitor.

The problem RasPi with the original SD card (Jessie Lite) works on an HDMI monitor (looks normal), my Dell 2009W DVI monitor (however the text is huge), but not on my Dell 1708FP (random screen flashes).

So, I know the monitor works. And I know the RasPi works. But the combination of that specific RasPi on the Dell 1708FP is an issue.

That makes no sense to me. Does anyone have any other ideas?

It's important to me to try and resolve this, because I'll be using 14 RasPi's to run videos on the 14 monitors during my bands live shows. I will be triggering/syncing the videos by broadcasting OSC messages to the 14 RasPi's. So, I need to know how to resolve this issue if it should occur again.

  • have you tried adding config_hdmi_boost=1 in config.txt? you can go higher, up to 11, but start low first – Jaromanda X Jul 19 '18 at 3:16
  • I did. I went as high as 7. I'll give 11 a try. Any long term affects I need to be concerned about with it set at 11? Seems there are a lot of dire warnings out there regarding that level of boost. – Chris Simeone Jul 19 '18 at 3:50
0

Problem Solved!

In a moment of desperation and frustration, I decided to try yet another Dell 1708FP monitor. I'm glad I did!

For some unknown reason, this particular monitor displayed a helpful message that basically said (I am paraphrasing) "Can't use current video mode. Please use 1280 x 1024 at 60 Hz."

So I edited the config.txt file yet again. This time I changed the video mode from 36 (75Hz) to 35 (60Hz), I uncommented "hdmi_drive" and set it to "1" which is Normal DVI mode (no sound), and I commented out any other active HDMI settings.

I'm not sure why the RasPi video output worked for a few days with the default config.txt (all settings commented out), and then decided to stop displaying output. But I happy it's functioning again. And I learned a lot about RasPi video configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.