0

I have a raspberry pi zero configured as a RNDIS/Ethernet Gadget. I installed the latest raspian image and followed the steps to set up for ssh etc.

When I first connected to the pi and shared the Internet connection on my Win 7 PC it worked fine. Then when I reconnected it stopped.

I am still able to ssh into the Pi but no Internet. I have rebooted but still no joy.

Looking through some fixes online, there was a suggested fix for someone who had the same issue. He disabled IPv6 and used local, but the issue was on a mac. I have no idea how it could be done on a Windows PC.

I have set the Pi with a static IP as when I had issues before, I did this and it worked at the beginning but has since stopped again.

I have disabled AV and firewall but it made no difference.

I also use VirtualBox on the Win7 computer and it creates a virtual network connection. Could it be causing an issue?

If you require more info please let me know, any help much appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.