1

I have been trying to configure my Raspberry pi 3 B+ as a 5Ghz access point but I'm unable to do so. Here is my hostapd

country_code=IN
ieee80211d=1 
ieee80211h=1

interface=wlan0
driver=nl80211

wpa=2
wpa_key_mgmt=WPA-PSK
rsn_pairwise=CCMP
wmm_enabled=1
ht_capab=[HT40][SHORT-GI-20][DSSS_CK-40]
macaddr_acl=0
ignore_broadcast_ssid=0
auth_algs=1


hw_mode=a
ieee80211n=1
require_ht=1
ieee80211ac=1
require_vht=1

vht_oper_chwidth=1
channel=36
vht_oper_centr_freq_seg0_idx=42

I get the following error

Failed to create interface mon.wlan0: -95 (Operation not supported)
wlan0: interface state UNINTIALIZED->COUNTRY_UPDATE
Could not set channel for kernel driver
Interface initialization failed
wlan0: interface state COUNTRY_UPDATE->DISABLED
wlan0: AP-DISABLED
hostapd_free_hapd_data: Interface wlan0 wasn't started
nl80211: deinit ifname=wlan0 disabled_llb_rates=0

I also tried setting channel=0 and channel=acs_survey but I keep getting the same error. How do I resolve this error? What is the proper hostapd for configuring my raspberry pi 3 B+ as 5Ghz AP? Is it possible to utilize dual band(2.4Ghz and 5Ghz) of the raspberry pi for an AP simultaneously? If so please post the hostapd for that too. Thanks in advance.

  • What is the contents of /etc/wpa_supplicant/wpa_supplicant.conf? – NomadMaker Jul 27 '18 at 18:11
1

Try starting with channel=48 and without using acs_survey. Once you get something working you can experiment from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.