2

I've been trying to get bluetooth working on my Raspberry Pi 1 Model B+ running Raspbian Stretch Lite 4.14 with a 3rd party USB bluetooth dongle.

I installed Bluez 5.43 for python 2.7, and was able to pair with another device using bluetoothctl. However, when I then try to connect a BluetoothSocket to that device, I get bluetooth.btcommon.BluetoothError: (13, 'Permission denied').

I found this thread with the same issue, and it was resolved by running sudo python script.py.

However, when I do the same and run the python script with sudo, the program still fails with the same error.

This is my python script. It is Python2.7 running on Raspbian Stretch Lite 4.14 using Bluez 5.43.

  • did you also try this answer in that same thread? – Jaromanda X Jul 28 '18 at 2:24
  • @JaromandaX Yes, I tried that solution as well, which also failed. After doing those steps, I still receive the same error. – coolioasjulio Jul 28 '18 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.