3

I am running arch linux on my pi.
My wifi adapter:

  Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

On the power front, 12W ipad adapter.

My suspicion was the "power saving feature" of the device. So I created an config file for the module in /etc/modprobe.d/ which disables power saving. It didn't work :(

  options 8192cu rtw_power_mgnt=0
  • I also have this chipset (RTL8188CUS, TP-Link TL-WN725N) and noticed that the Pi would reset upon plugging in this adapter. Using the adapter included by RS Components. – Lekensteyn Aug 2 '13 at 9:49
  • It resets? The adapter I have works for a couple of mins to a few hours. Then the led is just stable (Its blinks when there is some activity) . I can't ssh to the machine or anything. I am thinking of adding a cron job so that it pings the router every few mins or so. – feverDream Aug 2 '13 at 10:42
  • 1
    Yes, it reboots (due to the power flux?). What would the cron be good for? I suggest you to setup syslog and have a look in /var/log/. You might also be able to use journalctl -ab if the Pi has not reset (thereby losing logs) – Lekensteyn Aug 2 '13 at 11:07
  • The device I use is not connected to a display. So I am assuming that the pi is running and the wifi-adapter is not. I was under the impression that the adapter just shuts off due to inactivity. Hence the cron job. – feverDream Aug 2 '13 at 11:18
  • You can also SSH over Ethernet? Or do you have Model A? If PM is disabled, then the adapter will not go to sleep. – Lekensteyn Aug 2 '13 at 13:58
4

To disable power saving mode, you have to add "wireless-power off" in your "interfaces" file

1/ Type

sudo nano /etc/network/interfaces

2/ Add at the end of file

wireless-power off

3/ Reboot by typing :

sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.