3

So I'm having issues getting the USB boot mode working on my new raspberry pi 3b+ and a couple of different SSD's

I'll first go through all the things that I've done, and what I'm seeing.

  1. Installed Rasbian on an SD card
  2. Setup the USB Boot Mode in accordance to these steps from the SD card --https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md
  3. Reboot the R.Pi to write the OTP bit
  4. The vcgencmd otp_dump | grep 17: command checks out and I get the verified result
  5. I flash my SSD with etchio with the exact same image (I'm using rasbian lite) as the original on the SD card
  6. I boot the R.pi with the SSD plugged in via a SATA to USB 3.0 connection and the SD card removed.
  7. I see the "power" indicator on the SATA/USB connector light up for 2 seconds during the check cycle of the R.pi, but it turns off immediately after and doesn't boot leaving me with a black screen.

And thats where I leave basically.

I tried doing this with TWO different SSD's too...

https://www.amazon.com/gp/product/B01N6JQS8C/ref=oh_aui_detailpage_o03_s01?ie=UTF8&psc=1 -- A kingston 120GB SATA 3 SSD

https://www.amazon.com/PNY-CS900-120GB-Internal-Solid/dp/B0722XPTL6/ref=sr_1_3?ie=UTF8&qid=1532920058&sr=8-3&keywords=pny+120gb+ssd&dpID=51dLyw45hpL&preST=_SY300_QL70_&dpSrc=srch -- A PNY 120 GB SSD

And I'm using this Rosewill USB 3.0 to SATA 3 adapter cable -- https://www.amazon.com/gp/product/B06WVDK9QD/ref=oh_aui_detailpage_o02_s01?ie=UTF8&psc=1

The only thing I can possibly think is that the USB to SATA 3 cable isn't compatible? But I honestly have no idea, I'm at a loss. I just ordered a new one to test this theory.

It's probably worth noting that I also flashed a 32 GB Lexar Flash Drive and it worked! So it confirms that the USB Boot options works, but there is a problem with the SSD's.

I'm skeptical about power consumption, but I'm really no expect in this area.

Thank you all in advance

1

It looks like you are using a USB 3.0 device, no?

Well, the bad news is that raspberry pi (all models) dont support USB 3.0. If I remember right, USB 3.0 (among other things) uses more power that the pi provides. I might be wrong (Someone correct me if I am) but I am 99% sure that that is your issue.

You might be able to use a USB hub to power your drive, or get a different USB-SATA converter with a seperate power supply for your SSD.

If this is not the issue, that it could be that your SSD needs more time to boot. While this is unlikely, because SSD are fast, that could be it. You could try to get another USB-SATA cable but first you should try to ajust the period of time the pi will wait at boot.

Read this: Raspberry Pi 3 USB booting

Be sure to pay special attention to what Dmitry Grigoryev and Yorch said.

  • I actually ended up resolving the problem, but to give you some closure since you answered, yes this was basically the issue! The cable I was using was drawing USB 3.0 Power needs, and so I was browning out (I think thats the term) the SSD. I switched to a USB 2.0 to SATA connector and everything works perfect :) – Zane. R Sep 4 '18 at 18:19
  • which cable did you use? I am trying the HDD boot and I think that the converter on my cable is too slow, even though i added program_usb_boot_timeout=1 – lockheed silverman Sep 4 '18 at 23:15
  • 1
    Hey! So I actually have two solutions, one being I used an entirely new storage drive that worked way better, the other being what I did to get my SSD via SATA working OPTION 1. To get my SSD working, I used this SATA to USB cable amazon.com/gp/product/B011M8YACM/… It is listed as USB 2.0 so it worked! My SSD was low power enough to not need an external power source, if you're using an HDD like you mentioned I saw many people online say that you need to externally power it due to the R.pi not driving enough through the USB port. – Zane. R Sep 11 '18 at 16:29
  • (had to break up comments due to character limit) I saw people say that this powered cable worked for an HDD, but I can't confirm since I didn't use it.. amazon.com/gp/product/B06WWLCYC3/… – Zane. R Sep 11 '18 at 16:30
  • 1
    OPTION 2. (This is what I'm currently doing!) I bought an SSD thumbdrive, amazon.com/gp/product/B01MU8TZRV/… This thing works wonders. It's really fast I/O and I had no problems getting it to boot. Only thing to be careful of if you buy this is that it gets REALLY hot, so I had to run a USB extension cable just to dissipate some heat... Let me know if you have any questions! – Zane. R Sep 11 '18 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.