0

I've followed several tutorials on how to setup SSH through USB for my raspberry pi zero w. I've followed https://www.thepolyglotdeveloper.com/2016/06/connect-raspberry-pi-zero-usb-cable-ssh/ and https://www.youtube.com/watch?v=xj3MPmJhAPU which says the same things.

My raspberry pi zero W with raspbian appears on the wired connections on Ubuntu, and I can even connect to it. I activated it with ON and it displays connecting forever.

Look at my ifconfig on my laptop:

enp0s20f0u1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::5c6d:6621:10ce:3c88  prefixlen 64  scopeid 0x20<link>
        ether 1e:df:87:0b:23:bf  txqueuelen 1000  (Ethernet)
        RX packets 368  bytes 17203 (17.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 110  bytes 21428 (21.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Looks like my rasberry pi appears on my ubuntu with the ipv6 fe80::5c6d:6621:10ce:3c88. I even found out how to connect through ipv6 on ssh:

ssh -6 pi@fe80::5c6d:6621:10ce:3c88%enp0s20f0u1

but I always get connection refused.

Does anybody have any idea of how to do it?

UPDATE: I also tried https://raspberrypi.stackexchange.com/a/73665/74564 with no success. I see no IP information on ifconfig or the network GUI manager

UPDATE: I had to add an IP to the raspberry pi ethernet device. This answer is complete: https://raspberrypi.stackexchange.com/a/83647/74564

  • 1
    as a sanity check, is SSH enabled? Rasbian has it disabled by default (or at least at my last install it was). – bashCypher Jul 31 '18 at 0:15
  • @bashCypher yes it was. I found a way, see the update – Guerlando OCs Jul 31 '18 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.