1

I use a Raspberry pi 3 Model B

Today I tried to update my Raspbian OS(installed with berryboot) version from 09.05.2017 to the latest version. I was ssh'ed into the raspbian pi user(root) and typed:

sudo apt-get update
sudo apt-get upgrade

which i believe is a common practice. After a while once the update was done i rebooted the device:

sudo reboot

Suddenly my attached usb external storage was not mounted and i couldn't vnc into the machine anymore using the static ethernet ip address. I was able to connect to the RasPi only by using wireless connection. I switched wifi off hoping it would use ethernet again automatically but it was not what happened. I did a hard reboot of the machine and tried to work on it directly. My HID usb devices weren't recognized so I had no more controll over my raspberry. The only way to restore everything without reformatting the sd card was to manually replace the files on the sd card boot partition with the files from 09.05.2017 wich i got here.

After that everything was working fine again but I honestly don't even know if my Machine is updated and if I did something wrong regarding the update. I guess my Raspbian is up to date now and I just reversed the berryboot update which was not intended. My question is whether I updated my Raspbian OS or not and how should I do it in the future without messing up the berryboot files whatsoever? Also how do I update the berryboot firmware, if it obviously causes my ethernet and usb controllers to stop?

  • Do NOT include links to auto downloads. – Milliways Aug 1 '18 at 18:40
  • Uhm yeah sorry i forgot it was an auto download link. – patvax Aug 1 '18 at 19:29
0

I guess you are upgrading Raspbian Jessie or Raspbian Stretch but not Jessie to Stretch. Then the method you used with sudo apt update && sudo apt upgrade (I prefer apt) is the right one. You may consider to use sudo apt full-upgrade because that take a bit more dependency checks and deletes files no longer needed. That reduces the possibility for later conflicts with old files laying around.

The upgrade can only be done about packages that were installed from the repository. From other manual installed packages or compiled from source apt doesn't know anything. And that's the problem with berryboot. It will not be upraded by apt because it is not in the repository. Because apt doesn't know about berryboot it will "upgrade" its own boot files and firmware and may destroy berryboot and firmware load e.g. for ethernet and usb. Your other packages from the repository should have been upgraded in good order if you don't have seen error messages from apt-get.

A possibility to avoid this problem is to use u-boot-rpi from the repository as bootloader.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.