0

After upgrading the Raspbian operating system, I do not recognize the USBs (any of the 4 inputs) or the network port. I have a wireless keyboard and mouse connected via USB and I have also connected a mouse directly to all the USB ports, but it does not work.

The strange thing is that I have Berryboot installed, and when it comes to choosing the operating system, it doesn't recognize me either. Only the HDMI input and the power cable work.

Any idea what might have happened?

P.S. I have a Raspberry Pi3.

EDIT: The update was done through Raspbian:

sudo apt update
sudo apt dist-upgrade
sudo apt clean
sudo reboot
3
  • You have not said HOW you tried to upgrade, but Berryboot (at least last time I tried it) is rather particular about boot code and firmware. – Milliways Aug 4 '18 at 13:36
  • @Milliways I have edited the post to include the way I did the upgrade. I've reviewed the post and will try to fix it the way they say. Thank you – Alberto Aug 4 '18 at 14:22
  • Please read The Organizion's docs beginning with "Upgrading from Jessie to Stretch". – Seamus Aug 4 '18 at 15:11
1

According to the information you added to your question in the EDIT, you may have omitted an important step:

To upgrade, first modify the files /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list. In both files, change every occurrence of the word jessie to stretch. (Both files will require sudo to edit.)

Perhaps you can try again, and you may succeed; or it may fail due to the inconsistent state.

And I know nothing of Berryboot, but two things come to mind:

  1. will Berryboot not upgrade your OS for you?
  2. your upgrade efforts may have corrupted Berryboot

Bottom line: It may be quicker and easier for you to start from scratch; i.e. do a fresh install on your SD card.

Hope that helps.

7
  • This is poor advice; You omitted the important warning Upgrading an existing Jessie image is possible, but is not guaranteed to work in every circumstance. Even if it works additional steps are required to get all the Stretch features. – Milliways Aug 4 '18 at 15:56
  • I finally solved the problem provided by the related post. I replaced the content of my SD with that of the berryboot-20180729-pi0-pi0-pi1-pi2-pi3.zip file. I also checked the files etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list and both are with stretch. Thanks for your help – Alberto Aug 4 '18 at 16:09
  • @Milliways: Maybe you should read the answer again. I said "you may succeed, or it may fail". But I'd invite you to share your answer with us; we'll all be the wiser for it. – Seamus Aug 4 '18 at 18:41
  • I still think it inadvisable to encourage inexperienced users to do something most of us wouldn't - especially when you don't even know what OS is currently in use - the Foundation advice is to do a fresh install - which appears to be what the OP did – Milliways Aug 4 '18 at 20:29
  • @Milliways: ? Maybe you should read the question again... I can't see anything that suggests the OP did a fresh install. Did I miss something? And wrt your "poor advice" comment again, perhaps you could read my summation after the words "Bottom line:"; I certainly intended to suggest that a fresh install might be the way to go. But you clearly see things differently... fine, but don't sit on the sidelines and throw rocks, please. – Seamus Aug 4 '18 at 20:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.