Problem: External WiFi connect to Access point but does respond, static configuration does not work also, dhcp is OK

Configuration:

  • OS: Raspbian installated by NOOBS - only necessary things installated
  • WiFi: external USB: RT5370 (Ralink)
  • I followed this tutorial: http://pingbin.com/2012/12/setup-wifi-raspberry-pi/
  • I installated: firmware-ralink, wpasupplicant
  • wpa_supplicant.conf is done by wpa_passphrase, so it should be OK
  • /etc/network/interfaces:

    auto lo
    
    iface lo inet loopback
    iface eth0 inet dhcp
    
    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    

More info:

  • I have also tried static configuration with no DHCP, but it does not work also
  • I have also tryied adding this line to "interfaces" :

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1

  • I try that configuration with pings, because i don't have keyboard, nonetheless when I connect both ethernet and WiFI and restart the pi and connect wia SSH I see that both interfaces have their own IPs, I can connect wia SSH to both of them, BUT when I plug off the ethernet now also WiFi interface stops to respond on my signals - that strange!
  • When I try to setup the configuration manually with no etc/network/interfaces - WiFI connects to AP with wpa_supplicant command but when i type: dhlient wlan0 i see only blank screen as it was waiting on something
  • When I try to connect with VNC to try it graphically it says that i dont have any GUI :-(
  • Blue led on WiFi is on with that /etc/network/interfaces, but as I typed - no respond to ping signals.
  • I ping also other computer so, no problem with router I guess
  • when you say dhcp is OK does that mean it works with dhcp just not static? can you post of output of lsusb can you also post the output of dmesg – max Aug 4 '13 at 5:34
  • Have you tried rebooting with just the wifi in and not ethernet ? – Lawrence Sep 3 '13 at 6:47
  • Does your WIFI has a hidden SSID? Hidden SSIDs are a pain and can cause strange problems like yours. Un-hide it in case. – Alessandro Da Rugna Sep 3 '13 at 10:26

You installed Raspbian, which already has a wifi config installed. Just type 'startx' to start the GUI then open the wifi config.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.