I have a Raspberry Pi 3 and the lastest Raspbian is installed. I've run some java .jar file on it.
Now, I run an armhf Debian on my android device with Linux Deploy.

Is it possible to run Raspbian .img backup file to run on a chroot environment on an android device?
Otherwise, how is it possible to run java .jar file on armhf a chroot environment? (Oracle preferred)

  • Why would you want to run Raspbian if you already have Debian armhf running?
    – Dirk
    Aug 5, 2018 at 9:51
  • 1
    I run a project on Raspbian and I need JRE package. Up to now, I can't install JRE on Debian armhf. It's my main reason.
    – M. Rostami
    Aug 5, 2018 at 9:55
  • If your main concern is getting the Java Run-time Environment installed on Linux within Android ya might have an easier time installing it from source. Few years back I wrote a guide on installing JDK and JRE on Android running a Linux chroot, however, I'd advise not using the script as it has been sometime and last time I went through the steps I had to make an account with Java in order to access the archive as the use case I had at the time required the browser plugin too. Let me know if ya get stuck and I may post a full answer.
    – S0AndS0
    Jun 20, 2019 at 3:53
  • @S0AndS0 I changed plan and run centos on linux deploy as chroot environment. I'm curious about your guidance. All in all, thank you.
    – M. Rostami
    Jun 22, 2019 at 4:54
  • The easiest thing to try would be installing the openjdk-<version>-jdk and openjdk-<version>-jre from your distribution's package manager, eg zypper search openjdk should list'em if available on your device. If the application that requires JRE is happy with the open versions then ya don't have to mess with source installing, and if not let me know so that I can move this up the stack of planed project rewrites... it kinda needs a rewrite as it was written back for version Java versions 6/7 (when ARMel was still a thing) and things are up to 9 last I checked.
    – S0AndS0
    Jun 22, 2019 at 6:26

1 Answer 1


It might be good to update the question and perhaps have it moved over to the Android sub-stack

I run a project on Raspbian and I need JRE package. Up to now, I can't install JRE on Debian armhf. It's my main reason

As this is still on the RPi related sub-domain, the following I dug up from my notes on trying to get WebEx hosing and viewing on Raspbian.

Side note to readers, WebEx didn't really function but the basic steps are similar for other Browser + JRE apps so mileage may vary.

Install depends and compatible web-browser

apt-get install firefox-esr libcanberra-gtk-module gtk2-engines-murrine libxtst6 libxmu6 icedtea-plugin

Add non-sudo user without passphrase

useradd --shell /bin/bash --create-home --user-group moz

Login to new user and run web-browser

su - moz
$(which firefox-esr)

## Or all in one line
# su - moz -c "$(which firefox-esr)"

Download Java 7u4 for Embeded from the following link


Note, version is only important if using JRE/JDK for applications dependent upon the browser plug-in (.so file), above was the last version I could find with it still included, otherwise it's probably best to download the latest instead.

Un-Tar the dowloaded source

tar fvx ejre-7u4-fcs-b20-linux-arm-vfp-client_headful-12_apr_2012.tar.gz

Make a directory for Mozilla plugins

mkdir -p ${HOME}/.mozilla/plugins

Symbolicly link libnpjp2.so to the above directory


ln -s "${_plugin_source}" "${_plugin_dest}"

Restart Mozilla then navigate to the following URL


Click through prompts to allow stuff to run till either pass or fail

Other applications may require other (or all) bits to be symbolically linked, but the procedure is pretty much the same... well once one tracks down where an application expects things to be.

While the above was a failure in that WebEx didn't want to run on Raspbian, other things do work on either Android running a Linux chroot or an ARMhf computing development board, eg. the MapTools suite was totally functional albeit much, much slower on a single core ARMel Android over-clocked to 800MHz, and JMonkey once setup on an ARMhf device wasn't any more sluggish than running anything else over an RDP session forwarded over SHH.

As I'm not certain what application the OP is running on RPi and wanting to run on Android with Linux chroot, I think I'll have to call this answer as complete as it'll get without more information. Good luck!

  • What is the Android sub-stack? What is the RPi related sub-domain? Where do you execute these commands? On the android device?
    – Ingo
    Jul 6, 2019 at 8:36
  • 1
    Android sub-stack... You are here!... Yes on the Android device within a chroot Linux shell. Which is a process to setup but I've found use cases for such things... Generally over an SSH connection to the ARMel/hf device, but yes these are commands to run on the target... However, getting full JDK/JRE requires significantly more linking and updating of various executable paths such that other versions or OpenJDK/JRE do not conflict with the source installed version.
    – S0AndS0
    Jul 6, 2019 at 8:47
  • Thank you for the time that you have spent on answering this question. I preferred Oracle java, however, it's one of the solutions.
    – M. Rostami
    Jan 6, 2020 at 1:27
  • @M.Rostami You're very welcome! Recently I took another look at Oracle and found they've made things even more difficult to install, old guides suggesting a PPA are now broken because of licensing changes. So if your project doesn't require Oracle, as of 2020, it's going to be much easier to use OpenJRE/JDK. If you run into issues with a specific set of Java based software (that's freely available), feel free to tag (@) me within another question.
    – S0AndS0
    Jan 6, 2020 at 21:41
  • 1
    Oh, thanks for the update... One option to workaround limitations is to use a shroot setup instead of chroot; the Debian Kit application by sven-ola can be modified to run on ARMhf CPUs by following a Blog post by skyleecm, which should allow for accessing Android hardware from within the Linux environment. And setting up SSH can help with accessing the device from something with a full keyboard and larger screen too.
    – S0AndS0
    Jan 7, 2020 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.