3

I am having lots of problems connecting my raspberry pi zero to wifi. I have followed a number of tutorials.

1. What I have tried

This was my wpa_supplicant.conf file

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
#country=GB
network={
    anonymous_identity='@uni.ac.uk'
    ca_cert='/etc/ssl/certs/QuoVadis_Root_CA_2.pem'
    ssid="eduroam"
    scan_ssid=1
    key_mgmt=WPA-EAP
    eap=PEAP
    identity="username@uni.ac.uk"
    password="password"
    # phase1="peaplabel=0"
    phase2="auth=MSCHAPV2"
}

I created the ssh file on the sd card. I also enabled SSH through the raspi-config interface.

My ifconfig -a looks like the following:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 370  bytes 36228 (35.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 370  bytes 36228 (35.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.238.3  netmask 255.255.0.0  broadcast 169.254.255.255
        inet6 fe80::cdde:7301:7ba4:81d3  prefixlen 64  scopeid 0x20<link>
        ether 26:2e:19:0e:bb:4c  txqueuelen 1000  (Ethernet)
        RX packets 1459  bytes 139893 (136.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1424  bytes 224015 (218.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:e9:8e:33  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I tried turning the wlan0 on using:

sudo iwconfig wlan0 power on

2. The error messages I get

When I try scanning for wifi networks using

a) iwlist wlan0 scan

Could not communicate with wpa_supplicant

b) through the raspi-config network options

Could not communicate with wpa_supplicant

There was an error running option N2 Wi-fi

A major problem is that I only have a 4GB SD card and so I installed the Raspbian Stretch Lite OS. But then to install the GUIs I need wifi.

3. The question

I want to run these commands:

sudo apt-get install --no-install-recommends xserver-xorg
sudo apt-get install --no-install-recommends xinit
sudo apt-get install raspberrypi-ui-mods

Since I have managed to SSH into my Pi Zero W through USB - can I not use the internet from my laptop to download the packages.

Any help very much appreciated.

  • 1
    You may be wasting your time. It may be simpler to get an 8GB or larger SD card. What you want may not actually fit on a 4GB card. – joan Aug 6 '18 at 12:17
  • Fair enough! Is there any reason why the wifi connection might not be working? Thanks for your help – Tommy Lees Aug 6 '18 at 12:33
  • I'm afraid my wifi knowledge is too limited to offer any suggestions. – joan Aug 6 '18 at 12:42
  • 1
    try sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf on the command line - what errors do you see – Jaromanda X Aug 6 '18 at 22:50
  • You cannot communicate e with wpa_supplicat because it is not there. – Jan Hus Aug 7 '18 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.