0

Arch Linux ARM was installed successfully on a Raspberry Pi3 which will be added to a small network. The first attempt at setting up wifi on the Pi3 failed, showing alarm wpa_supplicant[323]: wlan0: Could not read SSID from driver.

The Pi3 is the only device that failed to connect. An Arch Linux laptop, and an Ubuntu laptop, both connected successfully using the same configuration.

Summary of steps

A very simple /etc/wpa_supplicant/wpa_supplicant-wlan0.conf was created:

# wpa_passphrase MYSSID mypassphrase > /etc/wpa_supplicant/wpa_supplicant-wlan0.conf

This produced:

ap_scan=0

network={
        ssid="MYSSID"
        #psk="mypassphrase"
        psk=long-alpha-numeric-key
}

Enable the service:

# systemctl enable wpa_supplicant@wlan0

A very basic systemd-networkd unit was created:

nano /etc/systemd/network/mypi3-wireless.network

This produced:

[Match]
Name=wlan0
[Network]
DHCP=yes

# reboot

(the systemd-networkd service is pre-enabled on ArchLinux ARM)

After rebooting and discovering no wifi connection:

# systemctl status wpa_supplicant@wlan0

Shows:

alarm systemd[1]: Started WPA aemon (interface-specific version)
alarm wpa_supplicant[3l32]: Successfully initialized wpa_supplicant
alarm wpa_supplicant[332]: wlan0: Could not read SSID from driver

This device attempts to connect to a Linksys ACM3200WRT router with OpenWRT. It is tempting to assume that this is an OpenWRT issue, however, the pi3 is the only device in the network that won't connect.

What am I missing? Thanks in advance.

  • is this a pi3 or pi3+? pi3+ won't enable wifi if regulatory domain is not set (e.g., in raspbian, you need to have country=XX in wpa_supplicant.conf) - if it's not a pi3B+ I apologise for the comment noise :p – Jaromanda X Aug 8 '18 at 4:52
  • It’s a Pi3. Your feedback is much appreciated. – justinnoor.io Aug 8 '18 at 5:00
  • what are the contents of /etc/wpa_supplicant/wpa_supplicant-wlan0.conf (obviously you can remove the ssid and password) - you've shown how you created it wpa_passphrase MYSSID mypassphrase > but does that do the whole job? – Jaromanda X Aug 8 '18 at 5:05
  • Jaromanda I updated the question. Adding ap_scan=0 got rid of the previous scanning error. But now I have an SSID related issue. Thanks again. – justinnoor.io Aug 9 '18 at 4:47
  • Nice, but could you elaborate WHAT are these entries , with exception of obvious "country" , for? Or point to a source of info to this effect ? – Jan Hus Aug 9 '18 at 13:48
0

This is , IMHO, one of THE better articles about implementing wireless. Eliminates lots of guesswork, but your mileage WILL VARY.

https://www.linux.com/learn/how-configure-wireless-any-linux-desktop

  • That article covers the iwconfig utility (which is now replaced with iw for the most part). While iw is a great tool, I need the ability to switch networks easily, which is why I’m using systemd-networkd! The issue I’m have is with the authentication part of the process, not with identifying my device. But thanks for your time, your help is much appreciated. BTW, no pun intended, but you might want to move that answer into the comment section as we are not supposed to answer questions with links stackoverflow.com/help/how-to-answer. – justinnoor.io Aug 9 '18 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.