0

i've never had this error since i bought my rpi3 last january. Any advice?

Details:

OS: Raspbian Stretch

Never edited /etc/network/interfaces as pi is attached to router via cable and had not needed to use wi-fi

journalctl -e (errors found)

vc_vhci_sm_init: failed to open VCHI service (-1)
[vc_sm_connected_init]: failed to initialize shared memory service

brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.10.41 Inc Compiler: 1.29.4 Inc ClmImport: 1.36.3 Creation: 2017-08-07 00:37:47

sd 0:0:0:0 [sda] No Caching mode page found
sd 0:0:0:0 [sda] Assuming drive cache: write through

dhcpcd.service: Failed at step EXEC spawning /usr/lib/dhcpcd5/dhcpcd: Exec format error

dhcpcd.service: Control process exited, code=exited status=203
Failed to start dhcpcd on all interfaces
dhcpcd.service: Unit entered failed state
dhcpcd.service: Failed with result 'exit-code'
  • What OS + version do you run? Did you modify /etc/network/interfaces? Please add that information to your question. – Dirk Aug 8 '18 at 7:28
  • Currently version is stretch and no modifications made to interfaces. Just used network cable to router from the beginning and thats it. This just happened today so I'm very confused. – Kurover Aug 8 '18 at 7:35
  • Please edit your question and add the output from ip addr. That will give an overview about the status of your interfaces. Look at journalctl -e for any error messages. – Ingo Aug 8 '18 at 7:43
  • Updated with results from ip addr and errors from journalctl -e – Kurover Aug 8 '18 at 8:17
  • Odd error starting dhcpcd5 (Exec format error). What does 'file' report on that file (should be a script)? Also 'file /sbin/dhcpcd' – Dirk Aug 8 '18 at 8:34
0

For those googlin' "failed to start dhcpcd on all interfaces" like myself:

  • NB: This is relevant to Raspbian Stretch; for a different release, the situation may differ.

Essentially, if your Pi has a wired DHCP connection, and you have eth0 in /etc/network/interfaces -- something like that :

# .. loopback interface ..
auto eth0
iface eth0 inet dhcp

Then it shall be enough and you can now disable dhcpcd.service :

systemctl disable dhcpcd

This shall be it -- reboot ( and don't forget to start your DCHP server, if your client is dhcp-bound ) and you shall not have this message for anymore.


Explanation: I suppose we have triggered dhcpcd.service into an enabled state, and since its Description field is "dhcpcd on all interfaces" -- it goes into the log file as "failed to start dhcpcd on all interfaces" . That's it.


  • Edit: fixed typos, thanks Ingo
  • Seems you have done some typos. There is no dhcpd service you can disable. Do you mean dhcpcd? – Ingo Jan 20 '19 at 13:57
  • @Ingo : thanks, it did not occur to me it has a 'c' there. I mean, I did it just not too long ago, but nevertheless did some typing mistakes here. Thanks again ) – ジョージ Jan 20 '19 at 14:58
  • Of course -- my bad. It is a client, therefore it shall go with a 'c'. – ジョージ Jan 20 '19 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.