1

I am new to pi. I setup my pi from NOOBS 2.8.2. My problem is that whenever I install any package by sudo apt-get install <PACKAGE NAME> command the package gets installed but when I try to run my device for the next time the device will not boot.

I thought this was my SD card or power supply problem but the device will work normal if no any package is installed. I tried many times by installing fresh NOOBS to my SD card, but the problem repeats.

---UPDATE--- Well it seems that there is problem with NOOBS. Everything works fine after installing raspbian without it.

  • This sounds extremely strange, and it's certainly not in line with expectations. Can I ask what packages you have tried to install this way, and if you have done anything at all besides installing a package before you try to reboot your pi? – Bex Aug 8 '18 at 17:57
  • any package - really? any at all? How many times have you done this? which packages did you install on each occasion? – Jaromanda X Aug 8 '18 at 23:31
  • @JaromandaX yes I initially i tried installing motion, now I try to install gedit, the problem is same. – Abhijet Aug 9 '18 at 2:41
  • @Bex all I have done is updated the apt and then tried to install the package. I tried to install motion for which the problem occured then for test I tried to install gedit, I faced the same problem – Abhijet Aug 9 '18 at 2:44
  • how much "free space" do you have on your SD card before you apt-get? did you try a different SD card (regardless if it works somewhere else) – Jaromanda X Aug 9 '18 at 2:46
1

Booting from a fresh flashed image and before installing packets you should do:

rpi ~$ sudo apt update
rpi ~$ sudo apt full-upgrade

Then reboot and install your software packet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.