I'm trying to connect my Raspberry Pi's to a WiFi network without success. Ethernet connection works flawlessly, but as I attempt to connect to WiFi using ADB as mentioned here, nothing happens. I have also tried to use the Android Things Setup Utility without success as can be seen in the terminal output.

When I try to connect through the menu option while running with a monitor connected, my particular network is not visible, even though my work's corporate networks are visible in the same menu. It should be noted that other devices are able to connect to the WiFi in question, and using any corporate network is not possible the project.

I have also tried

  • Using a cell phone as hotspot with similar result
  • Unplugging the ethernet cable when attempting to find networks(through the monitor interface)
  • Changing between password/open network
  • Both 2.4G and 5G
  • Changing SSID from uppercase to lowercase
  • Manually changing the /data/misc/wifi/wpa_supplicant.conf but cannot find any OS files on the SD card.
  • Reinstalling OS image.

I'm running Google iot_rpi3 v1.0.3

There seems to be no documentation on this issue, has anyone else encountered this problem?

Solved!

It appears as if the Wi-Fi list in the GUI only can display at most three network SSID's. This lead to the corporate networks effectively 'jam' access to my Wi-Fi as the list appears to be sorted by signal strength, and my network's RSSI was weaker than the corporate one's.

Will investigate further and possibly post a bug report to the public issue tracker.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.