0

My pi-top says this when it tried to boot and I tried the method of holding down shift when turning it on but I can't edit the program! Can somebody please help?

0

Sorry, been there, done that. I know that does not help you , but shift to "recover" did not fix anything for me either.

Your SD is most likely kaput - probably powered down at wrong time. . To verify - try reformatting it OUTSIDE Pi.

0

The boot loader cannot find the root partition. There are some possibilities which will fail boot up:

  1. The entry for root= in /boot/cmdline.txt is wrong.
  2. The entry in /etc/fstab for the root partion is wrong.
  3. The root partition isn't formated as ext4 filesystem
  4. There is no root filesystem on the root partition
  • None of the items mentioned would be as result of normal operation, right? – Jan Hus Aug 10 '18 at 23:45
  • @JanHus Right, they all will fail boot up. I have clarified my answer. – Ingo Aug 11 '18 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.