1

I'm trying to install PlaystaionNow on my Pi 3. It's an .exe Windows program so I found out I need to use Wine. Apparently for Wine to work you also need ExaGear.

So I start exagear:

Starting /bin/bash  in the guest image /opt/exagear/images/debian-8

Then try running the playstationNow.exe using:

~ $ wine PlayStationNow-11.0.0.exe

I get:

wine: cannot find L"C:\\windows\\system32\\PlayStationNow-11.0.0.exe"

So I cd to the downloads directory:

~ $ cd Downloads
~/Downloads $

then run wine again:

~/Downloads $ wine PlayStationNow-11.0.0.exe

It works but then I get these errors:

fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x565210, 0x565228) stub.
fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x538938, 43) stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:file:SetSearchPathMode (8001): stub
fixme:file:SetDefaultDllDirectories (800): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ver:GetCurrentPackageId (0x32fdb4 (nil)): stub

error message

I know that PlayStation now needs at least Windows 7. ExaGear comes with Wine 2.0 which only goes up to Windows XP. When I try to update Wine to the newest version it acts like it can't see it so I have to:

$ sudo apt-get install wine

This removes Wine 3.0 and reinstalls 2.0. and I'm back where I started. Please let me know what these errors mean and how to correct them?

  • sorry if this isnt possible I just thought I'd try since every tutorial has you using either A windows box or PS4 to connect to Psnow. – user304903 Aug 11 '18 at 4:56
  • 1
    i used winecfg to enter the wine configuration. I added secur32(native) to the library. By doing so I removed this errorerr:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution. – user304903 Aug 11 '18 at 6:41
  • You can install ntlm_auth through pip sudo -H pip install ntlm-auth – Brett Reinhard Aug 12 at 3:04
2

I'm sorry, but this isn't possible on the Raspberry Pi. WINE (Wine is Not an Emulator) is something that only works on the Intel platform. WINE only creates an environment that Windows code will work with on Linux, but it doesn't change the code.

The Raspberry Pi is built around an ARM processor. Therefore i86 code won't work on it.

There might be an emulator, but I could picture it running extremely slowly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy