1

I am running a Raspberry Pi 3B with a 7" touch display in kiosk mode. I am setting up Firefox to start on a specified web page, and have to specify the X server display number. User pi is set to auto-login, and launch Firefox by adding this line:

@firefox https:/10.1.1.224/admin/users/auto_pad --display=:0

to the file /home/pi/.config/lxsession/LXDE-pi/autostart.

When everything runs right, this is what the lightdm.log file shows:

DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log

I have about 20 of these devices in the field, and occasionally one of them changes to X-window display 1 after a reboot. This is what the lightdm.log file shows:

DisplayServer x-1: Logging to /var/log/lightdm/x-1.log

... but because Firefox is told to launch on display 0, the display just stays blank. And further reboots will launch display 1 every time...

until I change the line in the autostart file to:

@firefox https:/10.1.1.224/admin/users/auto_pad --display=:1

On the next reboot (or even just service lightdm restart), the displayserver switches back to display 0, but now Firefox is set to start on display 1, so the display is blank again...

Questions:

What makes the display server start on display 1 instead of display 0?
Why does it always toggle back to display 0 after I ask Firefox to start on display 1?
How can I force the display server to always start on display 0?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.