0

I've got a problem with my Pi3 B+ not reading my microSD card on boot (Red LED ON, Green LED OFF). The microSD I am using is a SanDisk U1A1-SDSQUAR-016G-GN6MA. I prepped the SD card with NOOBS and fired it up, and everything seemed to be working just fine. Raspian installed seemingly without issue, but when it went to reboot into the OS after install, it just never came back up. I get a solid red LED and no activity on the Green LED. I put the card into an older Pi A+ and it booted into Raspbian with no problems. So the SD card seems okay?

From there I tried a second Pi3 B+ to ensure it wasn't some kind of hardware failure with the first one. For this I did a complete overwrite format of the SD card with SD Card Formatter and then wrote the raspbian image directly to the SD card with Etcher. I wrote the June 27, 2018 image of Raspbian Stretch. On the 2nd Pi3 B+ it came up into raspbian with no issues. I configured some settings like connecting to the network and then rebooted via terminal command "reboot". The Pi shut down and never came back up. No boot, Red LED Solid but no action on the Green LED just like the first one.

Has anyone run into a problem like this before or know where I should check next? I don't understand why it would read the SD card with no problem the first time then have such a problem on reboot. I'm using a 2.0A power supply, which should be adequate to at least boot up [EDIT] I've hooked it to my bench supply now, which can provide 4A, so power is not the issue. Possibly an issue with the SD card? I don't actually see a listing for this specific card at https://elinux.org/RPi_SD_cards

[EDIT] I did some measurement of 5V and 3.3V rails and found that I get 5V (although a little funny looking, see image) and nothing on 3.3V. So not having 3.3V I imagine is a rather large issue. Any idea as to why it would just "go out" on two 3B+ boards after working on first boot?

[EDIT] I measured continuity with my meter, it's reading a short from 3.3V to GND (0.5 Ohms between them measured from the GPIO header). The question remains as to why this would 3.3V suddenly short off a soft reboot?

5V Rail (apologies for the photo rather than a capture, it's an old scope): 5V Scope Shot

  • The processor on the Pi3 is 64 bit, while the Pi 1 is 32 bit. The installations are not swappable. You will need to re-image a separate SD for the Pi3. See Raspberry Pi Hardware for more details. – RubberStamp Aug 15 '18 at 19:56
  • @RubberStamp If this was the case why would it boot at all on both? I was able to boot this card into Raspbian once on the Pi3, and I'm currently running it on the A+ v1.1 as we speak. It's the image I got from here: raspberrypi.org/downloads/raspbian – K_Trenholm Aug 15 '18 at 20:04
  • 1
    @RubberStamp All Raspbian installations (provided they are recent enough) will boot on ALL MODELS of Pi – Milliways Aug 15 '18 at 20:19
  • " I configured some settings like connecting to the network" - what specifically? – Milliways Aug 15 '18 at 20:25
  • @Milliways ... Thanks for the update. The last time I tried was about 9 months ago, and it didn't work. I guess I'll need to do some recalibrating of my internal gray matter knowledge base. – RubberStamp Aug 15 '18 at 20:31
1

This sounds similar to a problem I am currently having. I found this forum post on Adafruit's website https://forums.adafruit.com/viewtopic.php?f=50&t=138947&p=686882&hilit=Raspberry+Pi+3+will+not+boot+back+up#p686882 . It contains a few helpful troubleshooting techniques on both the asker's and answerer's part, but from what I see the power and the SD card do not seem to be the problem assuming you also used the power supply for the 2nd RPi3. On the post they did not find a solution so they got an exchange. If you purchased your RPi3 from Adafruit I highly suggest posting on their forum as well so their technical support engineers can have a look at your problem.

  • Thanks for the resource, I'll give this a read and see if anything jumps out. At this point I confirmed I'm at least giving it enough power, I have it hooked to my bench supply which can provide up to 5A, so that's ruled out at least. We did not buy these from adafruit, I think we bought them from Arrow. It seems really odd to me that BOTH of the 3B+ boards I've tried are both duds and both died in the exact same way. I figure there's got to be SOMETHING going on here. – K_Trenholm Aug 20 '18 at 15:17
0

Do you have another monitor to try the Pi on? Check your cables? Try turning off your power supply after boot then turning back on. Why not try etching raspbian straight to the SD card and booting straight into raspbian to see if the Pi are alive, then run raspi-config and update everything.

Hopefully some of these options work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.