0

I have a fresh installation of Archlinux ARM (7 or 8; tried both) on my Raspberry PI 3 Model B V1.2 but for some reason the WIFI does not work...

I created the file /etc/wpa_supplicant/wpa_supplicant.conf with the following content:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
update_config=1

When I now start wpa_supplicant everything looks fine...

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant

...but it isn't working:

[root@pi ~]# wpa_cli 
wpa_cli v2.6
Copyright (c) 2004-2016, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'p2p-dev-wlan0'

Interactive mode

> scan
OK
> 
> scan_results 
bssid / frequency / signal level / flags / ssid

So, as you can see, no results here.

What am I missing? What do I have to configure else?

1

In /etc/wpa_supplicant/wpa_supplicant.conf you have to configure at least one network you want to connect to, for example something like but with your settings:

country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="RPiNet"
    psk="verySecretPassword"
}

Check if your wifi device works with:

rpi ~$ sudo iw dev wlan0 info
rpi ~$ sudo iw dev wlan0 scan

You should get some info about your interface and a list of wifi networks from your neighbors.

0

Ok. Now I got it to work with netctl although I never really found out the reason for the issues with wpa_supplicant. But I want to share what I learned...

  • The country=XY setting is very important.
  • The interface might be disabled and must be enabled using ip link set dev wlan0 up.
  • One of the biggest problem in my case was (more or less unrelated to the issues above) that SSID broadcast was disabled on my access point for 2.4 GHz. I had it enabled for 5 GHz, so I thought my network is not hidden, but in fact it was hidden for my Raspberry Pi 3, because it only supports 2.4 GHz.
  • The country=XY setting is very important - I thought this was only for the 3B+, but it's good to know – Jaromanda X Aug 16 '18 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.