1

Recently I have been trying to get the 4ch microphone on the sony playstation 3 eye to work with my Raspberry Pi 3B (running the latest OS of raspian-stretch to date (2018-06-27 version) as a part of a home automation project. So far i've not had much luck even after going through many tutorials I found online and elsewhere.

It seems as if Alsa doesn't like the 4ch microphone array used by the webcam so when I try to run Alsamixer and select the sound card (F6) which is listed as "CameraB409241" under card 1 it spits out this error message

cannot load mixer controls: Invalid argument

So I read up that even though alsa mixer won't load the sound card up, I would still be able to record from the microphone so I tried both of the commands below

arecord -D plughw:1 -d 5 test.wav

arecord -D plughw:1 -c 4 -d 5 test.wav

And both times I was greeted with this error message

arecord: pcm_read:2103: read error: Interrupted system call

I have tried editing various config files some of which I couldn't find on my system and I have tried going down the pulse audio route, so far with no success. I know the PS3 eye mic is very good for voice recognition (I plan to install AlexaPi) and it would be nice to see it working.

If anyone could give me any extra information about how to get the 4ch mic array working on the pi or any other linux system it would be greatly appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.