My RPi 3 will not boot even after I have looked at every possible trouble shooting technique I could find. I plug it into the power and all it does it turn on the red led. I had it working for some time, but now it refuses to turn on. I've now tried 3 different power sources and 3 different SD cards and all have ended in the same result of it not booting. It gave me this same problem when I first got it, but after the 3rd SD card it seemed to have worked itself out. The current power supply and SD card are from Adafruit, so I trust that they are of decent quality. Could this be a problem with the manufacturing of the RPi? I've refused to believe it is, but I don't know what else it could be.

  • You need to edit your question and say what happens. The trouble shooting guides you have followed should indicate the diagnostic information you need to provide.
    – joan
    Aug 17, 2018 at 16:39
  • What do you mean by "say what happens"? All that the RPi does when power is supplied is turn on the red led. No green light and nothing displays. I am also not sure what other diagnostic information would be helpful. The power supply from Adafruit is the "5V" (that is actually 5.25V) 2.5A switching power supply. I have also used 2 others from which were 5V 2.5A. I have got it to run with the non-Adafruit power supplies. The SD card that finally worked consistently (until now) was an 8GB Sandisk bought from Adafruit. I don't know if that information was useful but help me help you help me lol.
    – jacob_m
    Aug 17, 2018 at 18:11
  • If you're certain that you've flashed the SD card correctly, then it's entirely possible your RPi is broken. Everything breaks eventually. Aug 20, 2018 at 8:48
  • I'm pretty certain I did. The SD card was working fine until the RPi stopped working and I have never cut power to the RPi while it was still running. I've only had it 5 months (;-;). I've contacted Adafruit to see if I can get an exchange.
    – jacob_m
    Aug 20, 2018 at 14:45

4 Answers 4


"I plug it into the power and all it does it turn on the red led."

Your troubleshooting technique is pretty standard and exhaustive and lacking green light of any fashion tells you have a dead hardware. No need to beat dead horse any more.

  • 1
    Thank you for your response. Are there any common causes to having this? I can't recall anything I may have done to cause it. Since this has happened since day one I really doubt it was, but it would still be helpful to be able to spot these causes and avoid them in the future.
    – jacob_m
    Aug 17, 2018 at 18:46
  • If I plug a Pi 3 in without an SD card, I get only the red led on. Does this mean I have "dead hardware"? In fact, all the models do this -- except the Pi 2, which does the opposite (the green led comes on solid instead of staying off). Put another way, no green led usually means either 1) No SD card inserted. 2) The SD card does not have a valid MBR. We get the latter pretty regularly here. However, it could mean the SD card reader or controller is busted.
    – goldilocks
    Aug 20, 2018 at 15:58
  • Mine has done this. Can some one check the output voltage of the raspberry supplied supply? Mine is giving out 5.2V when connected.
    – Robin
    Oct 1, 2018 at 8:06

To double check,

  1. Wait a day or two before trying to power up the pi again.
  2. When booting, make sure all peripherals are disconnected.
  3. Im not completely sure what you mean by "Got it working" does this mean you had successfully booted?
  4. Are your SD cards more than 8GB of memory?
  5. If you have the Raspberry Pi 3B+, try booting the raspberry pi from a USB drive as they might be something wrong with the SD card holder in the Pi.

I hope those basic troubleshooting techniques get you somewhere.


Use SD Formatter to clear the SD card. Get a fresh image and use Win32diskimager to write to the card or grab PiBakery.

Power the Pi on with the SD already inserted. Do you get the rainbow splash on the display? The 4 Raspberries (one for each core of the CPU)?

The USB boot option requires the Pi already have USB boot enabled.


"Are there any common causes to having this?" Yes, but there are no "official statistics" published about power problems in one place.

But if tell I have personally destroyed my SD by turning the power off on RUNNING system it will be ignored , edited or deleted.

However, any causal observer of this forum can detect few problems related to "strange behavior" which can be traced to power issues. Of course majority of users cannot or do not want to look at "whole picture" or get stuck on "answers" likes - get a bigger SD.

Not the answer you're looking for? Browse other questions tagged or ask your own question.