1

I recently reset my Android Things on my Raspberry Pi 3 because it was unable to find my own WiFi. After the reset I tried to go into settings and change the time zone to GMT+02:00.

If I click at any other time zone except GMT-07:00 or GMT-08:00 the list of available time zones jumps back up to the time zone currently selected (e.g. GMT-07:00).

This happens regardless of whether I have Automatic date & time selected or not.

I used to be able to set the time zone correctly and I have successfully programmed stuff on my Rasp Android Things for several months now. It was only after the factory reset that this occurred (although it is possible I have done something else to cause this).

I did not know what to call the "default screen" of Android Things, so below is an image to clarify what I mean by "default screen". EDIT: The image is just a copy/paste from the internet. I'm running version 1.0.

Example of Android Things "default screen"

  • First thing I'd recommend is updating to the latest image of Android Things. That alone may fix your time zone bug. – Nick Felker Aug 20 '18 at 21:19
  • Thanks for your comment. I did try to update AndroidThings but it said I already was up-to-date. – Crebit Aug 25 '18 at 10:31
  • If you're still on 0.6.0-devpreview, you should reflash your device to at least 1.0. – Nick Felker Aug 25 '18 at 21:06
  • Sorry, the picture might be misleading as it says version 0.6.0-devpreview. I just copied the image from the internet. I'm running 1.0 and I have updated it through the "start screen" settings. Starts screen says I'm up-to-date. – Crebit Aug 27 '18 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.