2

Hope I'm in the "right" place for this query. If not, please direct me to a more appropriate SE or other site, thanks.

I have a Pi 2B, to which I have USB connected an old DroboS and it works fine as a file server. What I'm looking to do now is to connect (via USB) my old (but very reliable and economic) Dell 1130 mono laser printer, to create a network printer.

We have a Macbook Air, Windows 7 laptop and an old Thinkpad running Linux Mint18, on our home network. I have drivers that work on all 3 of these machines so we know they are compatible. But, one has to carry the m/c and USB connect it to the printer, and that is less than convenient.

As Raspbian is based on Debian, I thought that the Linux driver, from Dell, would work but it fails at install (sh ./install.sh) with "unsupported hardware ARMv7" error. No surprise really!

The open printing listing has the 1130 as a "paperweight" printer (whatever that signifies) but no specific driver or gutenprint or "foomatic" options for it.

Is there a way to recompile (or something similar) to make it suitable for the CPU?

I've spent a good number of hours searching the web for guidance and am no further forward. Any help/suggestions (except "buy a new printer"!! Do you think I'm made of money!!:-) gratefully received.

Thanks in advance.

PB

  • You do have a toolchain on your RPi, but does Dell provide the source for their driver? Have you tried CUPS with a generic driver? Try Google: raspberry pi print server – Seamus Aug 20 '18 at 16:48
  • Google 'cups dell 1130'. github.com/cookiengineer/printer-driver-dell1130 has an armhf driver. No idea if it works – Dirk Aug 20 '18 at 17:20
  • @Seamus, afraid I am not familiar with toolchain. Currently researching it, will update if I find out/fix problem. Tried a number of gutenprint and foomatics but to no avail. – user90904 Aug 27 '18 at 14:58
  • @Dirk. Thanks for the tip,; downloaded from the link but when running dpkg at CLI I get "unable to find file -rastertosamsungspl. " Tired again from file manager (r/click file name, select "install package" which appears to run but then hangs with "Running" progress bar at max, and nothing more. Left it like that for couple of hours but it stayed that way. As you may be aware I'm not that smart with Linux so may be missing something fairly obvious to you experienced guys. As ever any help gratefully accepted – user90904 Aug 27 '18 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.