I know this is a common error, but I can now add another instance to the (rather long) list of people with this issue. The camera module isn't initialising the ENOSPC driver.

raspistill -o test.jpg
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Here are the solutions that I have tried so far:

  1. Installed the camera in the port next to the DVI socket and made sure that both ends of the ribbon cable are seated.

  2. Enabled the camera through a terminal on the PI via "sudo raspi-config"

  3. Updated the Raspberry PI firmware through a terminal with "sudo rpi-update"

  4. Increased the GPU memory available from the default of 128 to 144

  5. Used "sudo vcgencmd get_camera" to make sure that the camera is detected. (output from this command is: supported=1 detected=1)

  6. Checked that there is no other process accessing the camera: "sudo ps aux|grep raspi" the output was: pi 1097 0.0 0.0 4372 540 pts/0 S+ 09:09 0:00 grep --color=auto raspi

  7. Re-installed Raspberian via NOOBS from scratch, didn't change anything else, performed all of the above again and tore out the last strand of my hair as it still failed :).

Help please!

  • In desperation I have tried re-installing Raspbian from scratch again. I once again followed the steps above and once again achieved the same errors. I don't understand why, if the camera is working, it shouldn't work "out of the box", once the prerequisites have been met. There must be some way of obtaining some useful information that either tells what other process is locking the camera, or if the camera isn't responding at all. Commented Aug 22, 2018 at 22:30

6 Answers 6


I had exactly this problem. The camera was working fine and then didn't... Same error message.

I seemed to be able to solve it by $sudo raspi-config then re-enabling the camera in Interface Options, then rebooting.

Perhaps worth a try for someone before ordering a new cam.


I have used a software that streamed the camera signal. After manually stopping it with sudo service motion stop, the raspistill commands worked fine. So I guess it was a problem of accessing the camera, there were a demon thread blocking the usage for other programs.

  • One program that may run in the background is the snap picamera-streaming-demo. It is used in some tutorials. You can disable it via snap disable picamera-streaming-demo.
    – jens
    Commented Jun 24, 2020 at 15:49

I have seen the same but on most occasions found it was to do with the cable connections to the camera facing or not to the connections. Check a single camera cable on another Pi; if it works check combination of cables to give required lengths with one or other of the available cable connectors.


I had the same problem. I tried an older version of Raspbian 4.9.59 Nov 2017 and the camera worked. I then reflashed the SD card with the June 2018 download. I skipped the request to update when the Pi booted up. I'm running Raspbian 4.14.50-v7+ #1122 and the camera works now. When you update it, you get 41.14.62-v7+ #1134 so don't update. It has a bug.


No answers or suggestions from this forum. I asked the same thing on the Raspberry forum and am going to replace the camera.

Edit: 29th Aug 2018 New camera module arrived today, replaced and worked instantly. No software changes.

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented May 16, 2020 at 20:07

I had exactly the same problem, brand new Raspberry Pi HQ camera, worked fine and suddenly stoped with the same error message. Solution that worked for me : Preferences > Raspberry Pi Configuration > Interfaces > Disable the Camera and reboot your raspberry Pi. Once rebooted, do the same but this time enable the camera and reboot the Pi again. This should fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.