1

I've been struggling with getting into my Pi from Windows 10. I'm fairly sure the problem is on the Pi side but if so I can't for the life of me work it out.

In short, on Windows I cannot ssh or ping user@raspberrypi.local using the command line or putty via IPv6 (required by Bonjour apparently). Standard Raspbian install except for vnc server which is not running.

For reference, here is a list of things I already have done/know.

  • No problem from Linux - my laptop can ssh into user@raspberrypi.local without issue, but that uses IPv4.
  • SSH from CMD is working on Windows 10 - ssh into user@xxx.xxx.x.x works (but that's not the point damn it!)
  • Bonjour service is running on Windows 10 - have tried restarting it and the computer and it's running fine.
  • I can ping with IPv4 from Windows using ping -4 raspberrypi.local - no problem there, normal ping or ping -6 yield a Ping request could not find host raspberrypi.local. Please check the name and try again.
  • Avahi-daemon is installed on Pi and up to date, use IPv6=yes in the config file (avahi-daemon.conf) is there as standard. The daemon is running.
  • IPv6 is enabled on the Pi(I even added it to the Pi's modules not that that is needed anymore, worth a try).
  • Pi is updated, upgraded, up the wazoo.
  • The router doesn't appear to be playing silly buggers (it couldn't be as the other tests have worked but I checked and all is normal there - vanilla home router)

Anybody got any ideas to save the little hair I have left?

  • As I was writing this I discovered that I cannot ping6 anything from any device. I am beginning to suspect that the router is quietly killing the connection despite apparently supporting it. Has anyone come across this behavior before? Am I barking up a tree I really hope is there for my sanity?

EDIT: Since posting this, I managed to kill my router by disabling the DHCPv6 server and had to reset it to factory setting to get an outside connection again. Also, I don't have ULA mode on as recommended. I've tried ping6 with various devices now and no-one can talk to anyone inside or outside of the network (i.e ping6 user@machine.local fails as does ping6 ipv6.google.com). I am fully confused and out of my depth and cursing my curiosity for messing with this when I should be working.

  • Do you have a DHCP server which allocates IPv6 addresses or are you using the Link-local address? – Milliways Aug 22 '18 at 17:10
  • I'll not deny I'm still a bit of a noob here, but I'm assuming link local, as the router is set to stateless under the DHCPv6 menu. The only other option is deactivated. This is a crappy router from our ISP so I may be lacking in options here. – Bardoctorus Aug 22 '18 at 23:09
  • Just as an aside, why are you not following the recommendation to enable ULA? This should be enabled on your edge router which connects to your ISP equipment (but not on any interior routers you may have, as it would conflict). ULA ensures that all of your home equipment can connect to each other using the same IPv6 addresses even in the event of an ISP outage or renumbering. Using it is best practice. – Michael Hampton Aug 23 '18 at 14:28
  • I had been (wrongly I now see) advised to avoid it - I'll be giving it a try when I get back to my home network. As it happens, it's not essential that I make this work, I just want to understand what is going on with it really - I'll be sure to report back when I do it. – Bardoctorus Aug 28 '18 at 22:11
0

There is a lot missing and therefore you need to go through some steps to get it working.

In the first steps, use IP addresses instead of hostnames. If you have an DNS-problem, using IP addresses will make sure that this does not interfere with you getting ipv6 up.

From your description, I get the impression you're on simple network, with one router going to the outside world.

I also assume your IPv4 network works and therefore you have all your connectivity at layer 2.

So, you have a problem pinging your pi from w10. Can your pi ping your w10 on the link-local address? I'm not so much into windows, but you should be able to get the ink-local address from the output of ipconfig /all. It will look like fe80:......

Form your Pi, start a

ping6 -I eth0 fe80:....:...:

(cut-and-paste if you can to prevent typo's). The -I eth0 may be another interface name (for me it is wlan0). It is important that you specify the interface name, because for every interface, there is a fe80-network and you must be on the right one.

This should work. If it doesn't, make sure that on both systems, the use of IPv6 is enabled.

From your Windows system, you should be able to ping the yourself using:

ping -6 fe80::a19d:1727:6a5f:b906%5

The fe80-address is just an example; you got your own from the ipconfig /all The %5 is the number that is behind the fe80-address on the interface that you use on Windows. Yours may also differ. If that works, at least ping works on Windows.

Next hold your breath and try:

ping -6 fe80::addr:ess:ofpi:b906%5

Normally this should work.

  • Firstly, thanks for the detailed answer, I'll test it as soon as I'm back on my home network. Interestingly, I've had no problems whatsoever on site with my Pi and my Linux laptop, ssh into whoever@name.local works every time. I've been increasingly less W10 orientated and this is definitely more of a "I want to know what the hell is going on" situation than a "I need to know what the hell is going on situation. Still, I'll be sure to let you know if it works and do the appropriate doobley-doo to say you helped. – Bardoctorus Aug 28 '18 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.