1

I am new to the whole installing via the console thing. I try to install Qt 5.11.1 native on my Raspberry Pi 3 with Raspian Stretch according to this tutorial: http://www.tal.org/tutorials/building-qt-510-raspberry-pi-debian-stretch

I stumbled across this step:

Run configure with the following options:

PKG_CONFIG_LIBDIR=/usr/lib/arm-linux-gnueabihf/pkgconfig:/usr/share/pkgconfig \
PKG_CONFIG_SYSROOT_DIR=/ \
../qt-everywhere-src-5.10.1/configure -v -opengl es2 -eglfs -no-gtk \
-device linux-rasp-pi-g++ -device-option CROSS_COMPILE=/usr/bin/ \
-opensource -confirm-license -release -reduce-exports \
-force-pkg-config -no-kms -nomake examples -no-compile-examples -no-pch\
-skip qtwayland -skip qtwebengine -no-feature-geoservices_mapboxgl \
-qt-pcre -ssl -evdev -system-freetype -fontconfig -glib -prefix /opt/Qt5.10

I can't figure out how this works. I tried to run ./configure and then adding the options. This results in the following error:

Creating qmake... make: Nothing to be done for 'first'. ERROR: Assigning unknown variable 'PKG_CONFIG_LIBDIR' on command line.

How is this done right? Thanks in advance!

0

It's a bit hard for newbies like me. But appearently the first two lines of the code have to be excuted seperately.

Then you need to run the rest of the code as specified.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.