0

So I have been getting frustrated with the small sizes of micro SD cards and how volatile they are, so i was estatic that i could boot from an HDD...until i tried it 3 separate times over 2 weeks and it didnt work once.

the first time i followed all of the instructions in Magpi # 50 and got stuck when i couldn't execute the "sudo chroot /mnt/target" command. after running around all over the internet trying to find out why the 'chroot' command wont work, no dice, so i formatted the HDD and reinstalled the os (Raspbian, newest edition) on the card.

then i tried the adafruit tuturial ( https://learn.adafruit.com/external-drive-as-raspberry-pi-root/overview ). that didnt work either.

so last night i reformatted the drive and reinstalled raspbian, and refollowed the MagPi # instructions again this eavning. it went well, no errors, but when i shut down and ejected the card, than rebooted, the pi behaved like the time when i was a 16 year old noob who forgot to unzip NOOBs before i installed in on the card.

so what gives? i set the OPT fuse bit and got the correct message, etc.

right now i am using a 1 TB Seagate Pipeline HD 2 (SN #: 5V1XZK3 ) connected to a StarTech USB 2.0-IDE/SATA (PN #: USB2SATAIDE )

  • What is the content of cmdline.txt on the 1st (FAT32) partition on the hard drive - by the way, that adafruit article is about using a USB drive as root - it even says Unfortunately, no matter what you do, the Pi has to boot off an SD - yet you are clearly trying to boot (you DO have a raspberry pi 3B/3B+ right? ... i set the OPT fuse bit which one exactly? – Jaromanda X Aug 24 '18 at 5:00
  • i couldn't execute the "sudo chroot /mnt/target" - why not? did you get an error? – Jaromanda X Aug 24 '18 at 5:09
  • ok thank you for your help, Jaromanda X i later did relize that the adafruit tutorial was not what i wanted to do, so... when i tried to execute "sudo chroot /mnt/target" i got something to the jist of "file not found". but later i reinstalled raspbian so it works fine. i set the OTP bit that was specified in the Magpi #50 tutorial. the bit that allows for a USB boot. i am not sure of the exact name. i have a little bit older 2.5" SATA laptop drive with 160 GB of space, im going to try to boot that, if i cant get the 1 TB HDD to work. – lockheed silverman Aug 26 '18 at 4:10
  • I've added another possible issue to my answer below – Jaromanda X Aug 26 '18 at 4:13
  • so i did some tests . if my HDD is already spinning (powered by the power supply) and when i plug the USB/SATA cable in, it takes me on average about 8 seconds before my pi gives me the "removable media inserted" dialog. so that probably means that your right about the boot wait. ill fix that and try again. – lockheed silverman Aug 27 '18 at 3:11
1

The AdaFruit tutorial has nothing to do with booting from USB drive - it merely shows how to use a USB drive as a ROOT drive

Looking at the MagPi (so-called) tutorial on booting from USB drive - they make it sound far more complex than it actually is ....

once you've set the "fuse bit" - it's simple

  • "Burn" official raspbian image onto your USB Drive (thumbdrive, Sata Drive, doesn't matter) using the exact same method you used on an SD card (in windows, it used to be win32disk imager, or whatever the kids are using these days)

  • Attach USB driver to pi

  • Power it up

  • Profit

The only issues may be

  • how is the USB driver powered. Don't expect a Raspberry Pi to supply enough "juice" for an external hard drive
  • how long does the drive take to "become ready" - I think it needs to be ready within 5 seconds or the pi won't try to boot from it (not sure about this point though)
  • i have the HDD powered off of it own wall-wort supply. ive never had an issue with it before when i have used other IDE/SATA HDD for back-up/Archival. I tried to boot twice, and i waited about 20 seconds for the drive to boot and all i got was the single red LED glaring up at me. i did see the LEDs on the eathernet socket to flicker however – lockheed silverman Aug 26 '18 at 4:21
  • I'm fairly sure if the drive isn't "ready" within 5 seconds of the pi powering up, it can't boot from it. Powering a HDD separately doesn't mean it will "spin up" though - I have a similar setup (though I don't boot from HDD). The drive is permanently powered separately, but it doesn't begin to "spin up" until the Raspberry gets powered on – Jaromanda X Aug 26 '18 at 4:33
  • all right i think that i saw something about "changing the boot wait time" so i will look into that it actualy does take a while for it to spin up when it is unplugged but this peticular adaper/power supply keeps the HDD spining as long as its plugged into the wall. – lockheed silverman Aug 26 '18 at 4:37
  • OK I just noticed that my output when i execute the command :~ $ vcgencmd otp_dump | grep 17: that i get the output 17:3020000a not the output 0x3020000a. is that a fail or not? – lockheed silverman Aug 26 '18 at 4:50
  • no, it's 3020000a regardless - all ok – Jaromanda X Aug 26 '18 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.