1

I have Debian Jessie installed and needed to reinstall Apache. When I typed

sudo apt-get remove apache2

I managed to remove this package. However, any subsequent commands to apt-get produce a segmentation fault:

Package 'apache2' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  libonig2 libperl4-corelibs-perl libqdbm14 lsof php5-cgi php5-cli php5-common
  php5-json php5-readline
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 134 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Segmentation fault
/usr/sbin/dpkg-preconfigure: 6: /usr/sbin/dpkg-preconfigure: BEGIN: not found
/usr/sbin/dpkg-preconfigure: 1: eval: qq{: not found
/usr/sbin/dpkg-preconfigure: 8: /usr/sbin/dpkg-preconfigure: use: not found
/usr/sbin/dpkg-preconfigure: 9: /usr/sbin/dpkg-preconfigure: use: not found
/usr/sbin/dpkg-preconfigure: 10: /usr/sbin/dpkg-preconfigure: Syntax error: "(" unexpected
Setting up php5-common (5.6.36+dfsg-0+deb8u1) ...
Segmentation fault
dpkg: error processing package php5-common (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of php5-cli:
 php5-cli depends on php5-common (= 5.6.36+dfsg-0+deb8u1); however:
  Package php5-common is not configured yet.

dpkg: error processing package php5-cli (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-cgi:
 php5-cgi depends on php5-common (= 5.6.36+dfsg-0+deb8u1); however:
  Package php5-common is not configured yet.
 php5-cgi depends on php5-cli; however:
  Package php5-cli is not configured yet.

dpkg: error processing package php5-cgi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-readline:
 php5-readline depends on phpapi-20131226; however:
  Package phpapi-20131226 is not installed.
  Package php5-common which provides phpapi-20131226 is not configured yet.
 php5-readline depends on php5-common (= 5.6.36+dfsg-0+deb8u1); however:
  Package php5-common is not configured yet.
 php5-readline depends on php5-cli (= 5.6.36+dfsg-0+deb8u1); however:
  Package php5-cli is not configured yet.

dpkg: error processing package php5-readline (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 php5-common
 php5-cli
 php5-cgi
 php5-readline
E: Sub-process /usr/bin/dpkg returned an error code (1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.