1

I have a GSM HAT module which I am trying to use as a remote sms receiver, which my RPI will connect to using bluetooth. The problem I am facing is setting up a serial connection via bluetooth.

Out of the box I couldn't connect to the GSM HAT via bluetooth, but after digging I had to install these packages: bluealsa pulseaudio-module-bluetooth, start pulseaudio: sudo pulseaudio --start and restart bluetooth sudo systemctl restart bluetooth to successfully make a connection:

[bluetooth]# connect 38:1C:4A:2B:F0:F8
Attempting to connect to 38:1C:4A:2B:F0:F8
[CHG] Device 38:1C:4A:2B:F0:F8 Connected: yes
Connection successful
[CHG] Device 38:1C:4A:2B:F0:F8 ServicesResolved: yes

But looking through syslogs there are some worrying messages:

Aug 25 23:35:12 raspberrypi bluetoothd[475]: a2dp-source profile connect failed for 38:1C:4A:2B:F0:F8: Protocol not available
Aug 25 23:35:13 raspberrypi bluealsa[499]: /usr/bin/bluealsa: Unsupported AT message: CMD: command:+CLCC, value:(null)
Aug 25 23:35:13 raspberrypi bluealsa[499]: /usr/bin/bluealsa: Unsupported AT message: SET: command:+CLIP, value:1
Aug 25 23:35:13 raspberrypi bluealsa[499]: /usr/bin/bluealsa: Unsupported AT message: SET: command:+CCWA, value:1

To set up a serial over bluetooth connection I tried this config, but after a reboot it didn't work. It didn't even reconnect to a GSM HAT.

Then I tried setting it manually with sudo rfcomm connect hci0 38:1C:4A:2B:F0:F8, but I've got this:

humberd@raspberrypi:~ $ sudo rfcomm connect hci0 38:1C:4A:2B:F0:F8
Can't connect RFCOMM socket: Connection refused

I followed this guide. How to make it work?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.