2

I was tring to install PocketVj using this guide from the Github page. I installed all the dependencies using sudo apt-get install... with no problems. Followed by sudo pip install --upgrade pip again no problems.

Sudo pip install pjlink    and    sudo pip install python-osc

also worked without a problem. The problem I'm facing right now is svgtools. Here are the logs of my first attempt:

I had to use a picture in order to stay in the 30000 character limit, sorry My little understanding told me that I had to install the latest version of Cython. I did that with Sudo pip install Cython and no problems. However now I'm getting different problems when trying to install Svgtools.

enter image description here

From that output I get that SciPy is missing and the wrong version of numpy installed.

So I tried to install SciPy with sudo pip install SciPy and only get:

    pi@raspberrypi:~ $ sudo pip install SciPy
Collecting SciPy
  Using cached https://files.pythonhosted.org/packages/07/76/7e844757b9f3bf5ab9f951ccd3e4a8eed91ab8720b0aac8c2adcc2fdae9f/scipy-1.1.0.tar.gz
Building wheels for collected packages: SciPy
  Running setup.py bdist_wheel for SciPy ... error
  Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-ev3H7e/SciPy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-YAq9vb --python-tag cp27:
  /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
    warnings.warn(msg)
  lapack_opt_info:
  openblas_info:
    libraries  not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
    NOT AVAILABLE

  lapack_mkl_info:
  mkl_info:
    libraries mkl,vml,guide not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
    NOT AVAILABLE

    NOT AVAILABLE

  atlas_threads_info:
  Setting PTATLAS=ATLAS
    libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries ptf77blas,ptcblas,atlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries ptf77blas,ptcblas,atlas not found in /usr/lib/arm-linux-gnueabihf
    libraries lapack_atlas not found in /usr/lib/arm-linux-gnueabihf
  numpy.distutils.system_info.atlas_threads_info
    NOT AVAILABLE

  atlas_info:
    libraries f77blas,cblas,atlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries f77blas,cblas,atlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries f77blas,cblas,atlas not found in /usr/lib/arm-linux-gnueabihf
    libraries lapack_atlas not found in /usr/lib/arm-linux-gnueabihf
  numpy.distutils.system_info.atlas_info
    NOT AVAILABLE

  /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1427: UserWarning:
      Atlas (http://math-atlas.sourceforge.net/) libraries not found.
      Directories to search for the libraries can be specified in the
      numpy/distutils/site.cfg file (section [atlas]) or by setting
      the ATLAS environment variable.
    warnings.warn(AtlasNotFoundError.__doc__)
  lapack_info:
    libraries lapack not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
    NOT AVAILABLE

  /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1438: UserWarning:
      Lapack (http://www.netlib.org/lapack/) libraries not found.
      Directories to search for the libraries can be specified in the
      numpy/distutils/site.cfg file (section [lapack]) or by setting
      the LAPACK environment variable.
    warnings.warn(LapackNotFoundError.__doc__)
  lapack_src_info:
    NOT AVAILABLE

  /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1441: UserWarning:
      Lapack (http://www.netlib.org/lapack/) sources not found.
      Directories to search for the sources can be specified in the
      numpy/distutils/site.cfg file (section [lapack_src]) or by setting
      the LAPACK_SRC environment variable.
    warnings.warn(LapackSrcNotFoundError.__doc__)
    NOT AVAILABLE

  Running from scipy source directory.
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 474, in <module>
      setup_package()
    File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 470, in setup_package
      setup(**metadata)
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/core.py", line 135, in setup
      config = configuration()
    File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 388, in configuration
      config.add_subpackage('scipy')
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
      caller_level = 2)
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
      caller_level = caller_level + 1)
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
      config = setup_module.configuration(*args)
    File "scipy/setup.py", line 15, in configuration
      config.add_subpackage('linalg')
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
      caller_level = 2)
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
      caller_level = caller_level + 1)
    File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
      config = setup_module.configuration(*args)
    File "scipy/linalg/setup.py", line 19, in configuration
      raise NotFoundError('no lapack/blas resources found')
  numpy.distutils.system_info.NotFoundError: no lapack/blas resources found

  ----------------------------------------
  Failed building wheel for SciPy
  Running setup.py clean for SciPy
  Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-ev3H7e/SciPy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" clean --all:

  `setup.py clean` is not supported, use one of the following instead:

    - `git clean -xdf` (cleans all files)
    - `git clean -Xdf` (cleans all versioned files, doesn't touch
                        files that aren't checked into the git repo)

  Add `--force` to your command to use it anyway if you must (unsupported).


  ----------------------------------------
  Failed cleaning build dir for SciPy
Failed to build SciPy
Installing collected packages: SciPy
  Running setup.py install for SciPy ... error
    Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-ev3H7e/SciPy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-x1rbgQ/install-record.txt --single-version-externally-managed --compile:

    Note: if you need reliable uninstall behavior, then install
    with pip instead of using `setup.py install`:

      - `pip install .`       (from a git repo or downloaded source
                               release)
      - `pip install scipy`   (last SciPy release on PyPI)


    /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
      warnings.warn(msg)
    lapack_opt_info:
    openblas_info:
      libraries  not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
      NOT AVAILABLE

    lapack_mkl_info:
    mkl_info:
      libraries mkl,vml,guide not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
      NOT AVAILABLE

      NOT AVAILABLE

    atlas_threads_info:
    Setting PTATLAS=ATLAS
      libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/lib
      libraries lapack_atlas not found in /usr/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/lib/arm-linux-gnueabihf
      libraries lapack_atlas not found in /usr/lib/arm-linux-gnueabihf
    numpy.distutils.system_info.atlas_threads_info
      NOT AVAILABLE

    atlas_info:
      libraries f77blas,cblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries f77blas,cblas,atlas not found in /usr/lib
      libraries lapack_atlas not found in /usr/lib
      libraries f77blas,cblas,atlas not found in /usr/lib/arm-linux-gnueabihf
      libraries lapack_atlas not found in /usr/lib/arm-linux-gnueabihf
    numpy.distutils.system_info.atlas_info
      NOT AVAILABLE

    /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1427: UserWarning:
        Atlas (http://math-atlas.sourceforge.net/) libraries not found.
        Directories to search for the libraries can be specified in the
        numpy/distutils/site.cfg file (section [atlas]) or by setting
        the ATLAS environment variable.
      warnings.warn(AtlasNotFoundError.__doc__)
    lapack_info:
      libraries lapack not found in ['/usr/local/lib', '/usr/lib', '/usr/lib/arm-linux-gnueabihf']
      NOT AVAILABLE

    /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1438: UserWarning:
        Lapack (http://www.netlib.org/lapack/) libraries not found.
        Directories to search for the libraries can be specified in the
        numpy/distutils/site.cfg file (section [lapack]) or by setting
        the LAPACK environment variable.
      warnings.warn(LapackNotFoundError.__doc__)
    lapack_src_info:
      NOT AVAILABLE

    /usr/lib/python2.7/dist-packages/numpy/distutils/system_info.py:1441: UserWarning:
        Lapack (http://www.netlib.org/lapack/) sources not found.
        Directories to search for the sources can be specified in the
        numpy/distutils/site.cfg file (section [lapack_src]) or by setting
        the LAPACK_SRC environment variable.
      warnings.warn(LapackSrcNotFoundError.__doc__)
      NOT AVAILABLE

    Running from scipy source directory.
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 474, in <module>
        setup_package()
      File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 470, in setup_package
        setup(**metadata)
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/core.py", line 135, in setup
        config = configuration()
      File "/tmp/pip-install-ev3H7e/SciPy/setup.py", line 388, in configuration
        config.add_subpackage('scipy')
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
        caller_level = 2)
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
        caller_level = caller_level + 1)
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
        config = setup_module.configuration(*args)
      File "scipy/setup.py", line 15, in configuration
        config.add_subpackage('linalg')
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
        caller_level = 2)
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
        caller_level = caller_level + 1)
      File "/usr/lib/python2.7/dist-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
        config = setup_module.configuration(*args)
      File "scipy/linalg/setup.py", line 19, in configuration
        raise NotFoundError('no lapack/blas resources found')
    numpy.distutils.system_info.NotFoundError: no lapack/blas resources found

    ----------------------------------------
Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-ev3H7e/SciPy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-x1rbgQ/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-ev3H7e/SciPy/

Does anyone know how I can solve this problem and sucesfull install SciPy in order to get Svgtools up and running?

  • It's scipy, not scipi – Dirk Aug 26 '18 at 7:57
  • 1
    I fear you may be on your own with this. Debian/Raspbian ensure that the packages in their repositories are all mutually consistent. Once you download packages from other sources all bets are off. I can't see that anyone will be able to help unless they have done exactly the same as you. – joan Aug 26 '18 at 8:15
  • Please paste text rather than screen shots. It should work if you use the '{}' tool to keep the formatting. I cannot read the images. – NomadMaker Aug 26 '18 at 13:52
  • I originaly tried to do that but reached the limit of 30000 characters. – Torsten M.Torstenm Aug 26 '18 at 15:24
  • If you are actually running Jessie (which is obsolete) I suggest you install Stretch. This should have pre-compiled wheels for all common Python packages. See raspberrypi.org/blog/piwheels – Milliways Aug 26 '18 at 19:49
1

Where possible, installing packages through apt will save you a lot of trouble. Numpy and SciPy (note the -Py, not -Pi, as it's Python—not specifically Pi related) both have a lot of dependencies, and Pip generally tries to build the code directly rather than using pre-built packages as apt will.

The dependencies of svgtools are listed in the requirements.txt file of their repository. They are:

networkx
numpy
scipy
scikit-learn
pandas
scikit-image

So, you can try installing all of the above from the package manager:

sudo apt-get install python-networkx python-numpy python-scipy python-sklearn python-pandas

(scikit-image is not in the repositories so will have to be installed through Pip)

It may be wise to try to pip uninstall ... for any packages you have previously installed first.

Then, you can try running:

pip install svgtools

to see if compatibility is better with the system packages than installing numpy etc through Pip. That should automatically install scikit-image as required but hopefully will not need to build scikit-learn at all, avoiding the issues you've been having.

  • Your answer helped me alot. Trying to install the modules using apt-get and self compiling SciPy resulted in me being able to install svgtools. I used these instructions to compile SciPy. It seems like the pre compiled versions are sometimes not fully compatible with Raspbian (Jessy). – Torsten M.Torstenm Aug 29 '18 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.