0

I have been trying to get my PN532 NFC module to work using either I2C or SPI but neither way is working.

I have followed the instructions from the manufacturer for both I2C and SPI and originally through I2C wasn't getting communication (their chart for connection was off) but eventually got the cabling all correct - but this resulted in the following error:

nfc-list: ERROR: Unable to open NFC device: pn532_i2c:/dev/i2c-1

So I tried SPI and got to the same testing:

nfc-list: ERROR: Unable to open NFC device: pn532_spi:/dev/spidev0.0:280000

I get part one of SPI instructions 7 (If two devices are detected, it means the SPI is already opened.) so I should just be able to go ahead with nfc-list, but keep getting the above error.

I have tried trouble shooting using this chart (ITEAD PN532 on Pi 3 with libnfc) but all of the external links they used to provide full instructions as to what they did no longer work - so therefore can't actually use the troubleshooting because they don't explain it fully.

Would love any help that could be provided.

2
  • 1
    You need to choose an option (I2C or SPI) and then wire up that option. You then need to provide a clear photo or photos of your wiring together with a software listing with sample outputs. With all that information we may be able to help.
    – joan
    Aug 27, 2018 at 8:00
  • Does i2cdetect see your NFC reader? If not, you probably need to fix your wiring. Aug 28, 2018 at 12:20

1 Answer 1

1

Thanks Team,

I went back through to collect every little detail from setup (from booting a new OS and all), and applying my learnings in troubleshooting - most notably the wiring image on http://wiki.sunfounder.cc/index.php?title=PN532_NFC_Module_for_Raspberry_Pi is incorrect and you should be using pin allocation from https://myelectronicslab.com/wp-content/uploads/2016/06/raspbery-pi-3-gpio-pinout-40-pin-header-block-connector-1-1.png which results in the following table;

PN532 RPi pin 5V 2 (5V) GND 6 (GND) SDA 3 (GPIO02 SDA1 , I2C) SCL 5 (GPIO03 SCL1 , I2C)

Once I did this from a single boot everything worked fine. My issues must have been related to trying one way and then in my attempts to fix causing future attempts to not work either.

It can be a pain to start from a fresh slate, but I got there in the end and now everything is working as expected - YAY!

Thanks for your encouragement to provide more detail and recheck the wiring - hopefully this post helps others who are struggling with the same issue.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jan 15, 2020 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.