1

I have two WiFi networks configured in /etc/wpa_supplicant/wpa_supplicant.conf as below, and I'm able to manually switch from one to the other via GUI with no problems (via RealVNC usually).

However, if the hotspot gets rebooted or one of the networks disappears for a while it appears that the system doesn't recognize this and reconnect automatically to whatever it can see (I don't explicitly set priority because I usually know which network is on or off - the first one in the list is a mobile hotspot). If I restart the RPi 3 B+ then it does happily to connect to whatever it can see

On macOS I am used to it automatically switching to any network it has credentials for usually within a few seconds - is there a setting I need to adjust to make the behavior similar to macOS, or is there a newbie-safe way to set this up?

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=AU

network={
    ssid="ssid01"
    psk="******"
    key_mgmt=WPA-PSK
}

network={
    ssid="ssid02"
    psk="******"
    key_mgmt=WPA-PSK
}

Running Raspbian GNU/Linux 9 (stretch) on a Pi 3 Model B+

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.