1

On Raspbian, I just enabled VNC using the sudo raspi-config command and tried to use MobaXTerm to connect, but it gave me the error "No configured security type is supported by 3.3 VNC Viewer". I know most people use RealVNC but I'd prefer not to because even the standalone exe adds some /appdata and registry files. Is there any way to get the Raspberry Pi working with MobaXTerm VNC, or are there any portable VNC clients that are compatible with the Raspberry Pi?

2

I would like to Add in for Graphical methode

  1. "Option" --> "Security" --> Pop up - Windows with a link in Text Feld
    "User & Authorization" (German VNC: "Benutzer& Berechtigung")
  2. Click "User & Authorization" in text Field --> Popup-windows with Highlighted "Standard User"
  3. Click "Password- Button" --> Popup- window for changing password.

I use MobaXterm: you need only to set up the IP-Adress of Raspberry.

It is working both in RASPI 3B+ and RASPI 4. Have fun!

| improve this answer | |
1

So it seems like the VNC server bundled with Raspbian is the RealVNC server, which uses an authentication protocol that isn't compatible with many VNC clients, including MobaXTerm and TightVNC. Seems a little ridiculous for Raspbian to bundle proprietary software that uses it's own special protocols.

The good news is it's possible to reconfigure the RealVNC server to use the normal authentication protocol. We basically just need to change the "Service Mode" configuration to use "VncAuth", and add a password.

First, make sure you enable VNC using sudo raspi-config, going to interfacing options, and then for VNC select yes. Then follow the instructions below.

Graphical Method

If you have a keyboard+mouse+monitor connected to the Raspberry Pi, you can just

  1. click the Vnc icon in the top bar, open the hamburger menu, and select "Options..."
  2. Under the "Security" tab, for "Authentication" choose the "VNC password" option
  3. Under "Users and Permissions" tab, select "Standard User" and click "Password..." to set your VNC password
  4. reboot the RPi, and you should now be able to use your preferred VNC client to connect!

(disclaimer: I haven't tested this method, just stuff I read online, so if you find issues/corrections please let me know in the comments!)

Command-Line / SSH

If you're SSHing into the RPi like me, you can

  1. modify the config file: sudo echo 'Authentication=VncAuth' >> /root/.vnc/config.d/vncserver-x11 (might need to be logged in a root to do this)
  2. add the password to the config file: sudo vncpasswd -service (will prompt you to set a password)
  3. sudo reboot
  4. you should now be able to use your preferred VNC client to connect!

References and Docs

graphical method

command-line configuration

Authentication parameter and Password parameter

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.