1

I installed raspbian using NOOBS in raspberry pi 3 B+ . I enabled ssh in Pi .By typing ifconfig I obtained ip address .Using putty from windows I entered ip ,username and password I am getting access Denied in putty .I checked ip, username, password twice .From windows I was able to ping Pi(ping 192.168.1.33). but from Pi side ping is not working (ping 192.168.1.34 Windows ip). can anyone please suggest me the solution to ssh Pi. Thankyou in advanced

  • I enabled ssh in Pi how? – Jaromanda X Aug 30 '18 at 23:42
1

Are you sure that you have enabled SSH?

You can check if SSH is running by running the following in a terminal

sudo service ssh status

Here are 3 methods to enable SSH

Preferred method if running under Raspbian desktop

  1. Launch Raspberry Pi Configuration from the Preferences menu
  2. Navigate to the Interfaces tab
  3. Select Enabled next to SSH
  4. Click OK

Using a terminal (IE: No desktop available)

  1. Enter sudo raspi-config in a terminal window
  2. Select Interfacing Options
  3. Navigate to and select SSH
  4. Choose Yes
  5. Select Ok
  6. Choose Finish

Alternatively, use systemctl to start the service if the above 2 options do not work, however I would really recommend the above 2 options, before this method.

  1. sudo systemctl enable ssh
  2. sudo systemctl start ssh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.