1

I am trying to enable 5 Ghz on my Pi because the speed I am getting is 10 Mbps or less while my old HTC M7 on 5Ghz is able to get 80 Mbps but raspbian is not letting me change the country to enable 5 Ghz, below are the things I tried.

  1. Changing WiFi location from raspbian preferences.
  2. Changing WiFi Location using command sudo iw reg set US [Results in GUI saying wifi country not set]
  3. Changing country in /etc/wpa_supplicant/wpa_supplicant.conf
  4. systemctl disable wifi-country.service

$ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: hci0: Bluetooth Soft blocked: no Hard blocked: no

I found below in Raspbian change log: WiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only) - The domain can be done through 'Raspberry Pi Configuration' (rc_gui), 'raspi-config' or by setting 'country=' to an appropriate ISO 3166 alpha2 country code in /etc/wpa_supplicant/wpa_supplicant.conf. * Default wireless regulatory domain is now unset

I found following behavior: If I connect to access point which has country set to US then US is set in raspbian too (confirmed using sudo iw reg get and I could see 5 Ghz access point). If I connect it to my other router (which I don't have access to see or change config) it goes back to a neighbouring country.

So is there anyway left I could change the country or I have to change the distro to solve this problem.

  • Either 1 or 3 will work. You SHOULD NOT use iw to set configuration. If it isn't working list what YOU DID. – Milliways Sep 1 '18 at 3:30
  • a neighbouring country - which one? – Jaromanda X Sep 1 '18 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.