1

I'm bought a (notebook) display LP171WP4 (TL)(01) and a display controller. Both are working if I connect it to my Macbook via HDMI. But with the Raspberry PI 3 B it doesn't work. The display is on HDMI but showing 'no signal' on the HDMI channel. If I connect my Raspberry to my TV via HDMI is working fine.

I tried to change different lines in the /boot/config.txt and rebooted after each try without any success.

This is what I've tested:

  • hdmi_force_hotplug=1
  • hdmi_group=2 & hdmi_mode=46/hdmi_mode=47
  • hdmi_drive=2
  • hdmi_safe=1
  • config_hdmi_boost=4 7, 11 I changed the HDMI cable to 1.5 meters as well

Once I don't remember which settings I had, I got a signal, but it was just for a one second followed by several seconds black screen and these two states were repeating, but of course not usable.

Here some debugging info:

$ tvservice -s
state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

$ tvservice -n
device_name=DWE-HDMI

$ tvservice -M
Starting to monitor for HDMI events
[I] HDMI cable is unplugged
[I] HDMI is attached

$ tvservice -m CEA
Group CEA has 15 modes:
       mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
       mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
       mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
       mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
       mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
       mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
       mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
(prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
       mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
       mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
       mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
       mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
       mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced
(native) mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
       mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive

$tvservice -m DMT
Group DMT has 14 modes:
       mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
       mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive
       mode 8: 800x600 @ 56Hz 4:3, clock:36MHz progressive
       mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
       mode 10: 800x600 @ 72Hz 4:3, clock:50MHz progressive
       mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive
       mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
       mode 17: 1024x768 @ 70Hz 4:3, clock:75MHz progressive
       mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive
       mode 32: 1280x960 @ 60Hz 4:3, clock:108MHz progressive
       mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive
       mode 36: 1280x1024 @ 75Hz 5:4, clock:135MHz progressive
       mode 47: 1440x900 @ 60Hz 16:10, clock:106MHz progressive
       mode 85: 1280x720 @ 60Hz 16:9, clock:74MHz progressive

I tried to follow these instructions, part 'The resolution and HDMI modes are not the best values for your screen' and set these values (because I had same result from the edid.txt file:

hdmi_group=1
hdmi_mode=16 

But that didn't help.

I bough a different controller with VGA and a different monitor which supports similar displays, same result.

  • raspberry runs with 3 amps and rasbian-stretch
  • display controller runs with 12 volts, 3amps (as recommended)

enter image description here

0

I bought a HMDI to VGA adapter (by UGREEN) and now it's working.
The adapter needs power via micro USB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.