2

I tried to install Mapscii on a raspberry pi, but for some reason the list of character that it is able to display seems limited. I've Jessie light installation, no GUI, but the strange thing is that i've tried to connect different display to the pi, and i always got squares character instead of the unknow ones (mainly braille characters), except that it properly display the everything trough a ssh connection.

Does someone can help me?

Thanks

  • To me it sounds like the used font does not support all the characters you use. Have you tried to connect via SSH and see if it still does not work? – kwasmich Sep 6 '18 at 8:37
  • yes, i think is exactly that, indeed in ssh works fine. so what can i do? i heard of fbterm, or passing to the X environment, but i there a way to just install a more extended font? – piLeoni Sep 6 '18 at 8:39
  • Including a link to mapscii ... is this one correct? may be a good idea so people know a little bit more about what you are asking... – RubberStamp Sep 6 '18 at 11:47
  • yes it is actually, i've inserted it in the question. – piLeoni Sep 6 '18 at 17:42
1

MAPscii homepage tells you in the first sentence than it needs an xterm-compatible terminal. Braille characters are unicode (they really should've called it MAPunicode and not MAPscii), and the default font management system (fontconfig) is part of X. There are alternatives (google tinyfont, ft2tf and fbpad) but by far the easiest solution would be to install xterm (which will pull the whole X GUI system) or fbterm (which will pull fontconfig and all its dependencies). You can also configure your virtual console to use unicode using /etc/sysconfig/console or unicode_start, but you still need to install unicode fonts for this to have the desired effect.

You probably run your SSH client in either Windows (putty) on in X environment (inside xterm), that's why MAPscii works via SSH.

  • first of all thanks. Anyway i tried fbterm but with little success, documentation is really quite technical for a beginner. Initially i was only getting: stdin isn't a interactive tty! (from ssh) Then i tried: fbterm <> /dev/tty1 Learning in the while about stdin, stdout and ttys. But it was anyway quite messy, with two cursors, and unable to stream that or other node based app on it, or to set it as default. If you have some advise that would be my first choice. – piLeoni Sep 12 '18 at 11:15
  • About /etc/sysconfig/console or unicode_start, are those something requiring fbterm as well or a just setting the standard linux console being able to visualize those glyps? – piLeoni Sep 12 '18 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.