0

I am attempting to install Cyberduck CLI on a Raspberry Pi 3b+ that has the default Raspian. I am aware that there is a UI available, however for the purposes of writing a script to automate mass file transfers, I wish to use the Cyberduck CLI.

I have followed the user instructions as outlined here.

However, when I ran

sudo apt-get install duck

A different package was installed, also called duck, created in 2017 by Simon Kainz. This package does not support the webdav file transfer that I intend to use duck-CLI for.

I have raised a ticket to the Cyberduck website here that describes the steps taken.
The Cyberduck team updated their installation instructions and then advised me to install against a specific version using

sudo apt-get install duck=6.7.1.28683

Unfortunately this results in

E: Version '6.7.1.28683' for 'duck' was not found.  

I have tried a variety of other versions, including purging and uninstalling the current duck package, but I can't seem to find any way to locate the Cyberduck CLI package instead of this other duck package.

I'm sure other people must have been able to install Cyberduck cli on their Pi. How should it be done?

0

For RPM Package:

 echo -e "[duck-stable]\nname=duck-stable\nbaseurl=https://repo.cyberduck.io/stable/\$basearch/\nenabled=1\ngpgcheck=0" | sudo tee /etc/yum.repos.d/duck-stable.repo
    sudo yum install duck

For DEB Package:

echo -e "deb https://s3.amazonaws.com/repo.deb.cyberduck.io stable main" | sudo tee /etc/apt/sources.list.d/cyberduck.list > /dev/null
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FE7097963FEFBE72
sudo apt-get update
sudo apt-get install duck

For other installation option you can check the following link Installation option

  • Hello. I am using Raspian, and have installed following the Debian package instructions. Unfortunately, I have already completed all of the steps that you have listed here, as outlined in the initial ticket which I had linked in my question, above. I still receive Simon Kainz's duck, and not Cyberduck CLI, when I perform sudo apt-get install duck. – Sky_Paladin Sep 10 '18 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.