0

i read all of the posts here and commentated on one of them but comment was deleted as it was a question i guess, so i mage my own now, sorry for that...

Ok the problem:

USB sound card mic is not working, but when i edit the ~/.asoundrc to:

pcm.!default {
  type plug
  slave {
    pcm "hw:1,0"
  }
}

ctl.!default {
  type hw
  card 1
}

The mic and speakers start working, everything is great again!

and then i reboot and everything is back to:

pcm.!default {
  type hw
  card 1
}

ctl.!default {
  type hw
  card 1
}

and after that nothing works again (whell sound works but mic does not)

i have disabled BCM driver load in boot.conf and aplay -l and arecord -l returns only USB sound card.

so the big question of the century is how can i force the config file to stay the same as i have written? read only doesnt work it just throws error and stops loading UI, config in /etc/ also does not work. i have updated everything and upgraded also...

what now?

thanks!

1

Ok, it is weird but for now at least works... i changed boot config file back to:

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

I had it turned off previously, and now it shows that it loaded bcm as a default device, but keeps the .asoundrc file alone and sends sound through the USB also the mic works...

Im confused, but yea...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.