11

I'm having problems getting audio over HDMI working correctly (running ArchARM). I have in my /boot/config.txt:

hdmi_drive=2

I compiled hello_audio.bin and ran it with 0 and 1 as args, both work (through the TV and the jack)

Sound over the analogue jack works fine with aplay when I switch with:

amixer cset numid=3 1

But I can't get aplay to play wav files over HDMI (I switched to hdmi with amixer cset numid=3 2)


Just to update: I can play mp3 files in mpg123/mplayer over HDMI but still no luck with wavs.

5
  • Are you root? Commented Jul 2, 2012 at 15:00
  • Yeah I've tried all the above as root and as a normal user (which I added to group audio)
    – Munkeh
    Commented Jul 2, 2012 at 15:04
  • Have you solved this @jake? Commented Jul 6, 2012 at 18:15
  • I have same symptoms as you: hello_audio.bin works to either analog or HDMI output (with 0 or 1 args respectively). aplay over analog jack works with amixer cset numid=3 1 aplay over HDMI does NOT work with amixer cset numid=3 2 I have also set hdmi_drive=2 (otherwise hello_audio.bin doesn't work over HDMI) I have the B version (256MB) of the raspberry pi, running 2012-10-28-wheezy-raspbian.zip. (Sorry I would have posted this as a comment instead of an answer but comments seem to be closed??)
    – user3165
    Commented Nov 5, 2012 at 0:35
  • I never managed to solve this by the way. Maybe it's something to do with the way ALSA decodes WAV over the HDMI driver, fsck knows! Not an issue any more, but still mystifying.
    – Munkeh
    Commented Dec 17, 2012 at 0:39

2 Answers 2

3

this worked for me:

omxplayer -o hdmi audiofile.wav

it seems that aplay doesn't really do a good job sending audio through hdmi in other formats either, it turns everything to mono, 8bit, and 8000hz or something. Anyway, that worked for me!

2

I'm pretty sure you have to specify the device with aplay like this:

aplay -D plug:hdmi music.wav
6
  • If this is true, then this answer is wrong. Commented Jul 2, 2012 at 15:52
  • If this isn't true then that answer is right.
    – Jivings
    Commented Jul 2, 2012 at 15:54
  • No, silly CS students... Commented Jul 2, 2012 at 15:55
  • 1
    That yields an error about an unknown PCM. There's no mention of plug:hdmi in aplay -L. Only default:ALSA
    – Munkeh
    Commented Jul 2, 2012 at 15:59
  • @Jake Have you tried using omxplayer? I'm sure that will dispel all of your problems.
    – Jivings
    Commented Jul 2, 2012 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.