1

Problem with unbound and pi-hole

I followed the official guide for installing Unbound alongside Pi-hole for my network, see Setting up Pi-hole as a recursive DNS server solution

A week ago I first followed this guide with a fresh installed Raspbian (lite) and everything worked out of the box. But today I followed the guide again (with a fresh install also) for my Pi-Zero at home and I just can't get unbound to work...

With dig pi-hole.net @127.0.0.1 -p 5353 I always get "SERVFAIL" and if I look at the unbound.service I either get:

unbound[1187]: [1187:0] info: failed to prime trust anchor -- could not fetch DNSKEY rrset . DNSKEY IN

or something along the line of the anchor is NOT ok and could not be fixed

I have no idea why that keeps happening. I tried sudo unbound-anchor -v -a /var/lib/unbound/root.key (and other possible remedies I found online - like uninstall / using unbound-user etc) to reset the root.key-file but the anchor still fails.

Any help would be appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.