3

I have my cam module connected and have also tried sudo apt-get update && sudo apt-get upgrade but the pi is unable to detect the cam module.

On executing this command : vcgencmd get_camera

outputs: supported = 0, detected = 0

Why does it say supported = 0? Is there something wrong with the operating system?

4
  • Which OS is running? Did you enable the camera in 'raspi-config' or the 'Raspberry Pi Configuration' utility on the desktop?
    – Dirk
    Commented Sep 16, 2018 at 22:45
  • It is running raspbian stretch. There is no option for camera in the raspi-config
    – Sab
    Commented Sep 16, 2018 at 23:39
  • There is: option 5 (interfacing) / P1 (camera)
    – Dirk
    Commented Sep 17, 2018 at 0:50
  • BTW: supported=0 means that the camera is not enabled
    – Dirk
    Commented Sep 17, 2018 at 0:57

1 Answer 1

8

You need to run sudo raspi-config and enable the camera from there before you can use it. The main menu should have an "Interfacing Options" submenu (probably #5). From there the option to enable the camera should be clear.

You will need to reboot after that.

What this does is add/enable (uncommented, ie. with no leading #):

start_x=1
gpu_mem=128

within /boot/config.txt. If the camera is not enabled after you reboot, check that file to make sure. Those should not be commented out (meaning there should be no # at the beginning of the line).

1
  • Wow that made the trick. I've raspbian bullseye so there is no option to enable/disable the camera from raspi-config. Adding manually "start_x" in the /boot/config.txt file solved my problem. Maybe someone with a new camera could add "camera_auto_detect=1"
    – Davide
    Commented Jul 7, 2022 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.