I am using the Raspberry Pi 3 B+ w/ Raspbian Stretch.

I am currently unable to view the video stream on port 8080 or 8081. When I start the command: motion -s "test" recipientemailhere This is what it outputs in the terminal:

[0:motion] [NTC] [ALL] conf_load: Processing thread 0 - config file /home/admin/.motion/motion.conf
[0:motion] [NTC] [ALL] motion_startup: Motion 4.0.1 Started
[0:motion] [NTC] [ALL] motion_startup: Logging to syslog
[0:motion] [NTC] [ALL] motion_startup: Using log type (ALL) log level (NTC)
[0:motion] [NTC] [ENC] ffmpeg_init: ffmpeg libavcodec version 57.64.101 libavformat version 57.56.101
[0:motion] [NTC] [ALL] main: Motion running in setup mode.
[0:motion] [NTC] [ALL] main: Camera 0 is from /home/admin/.motion/motion.conf
[0:motion] [NTC] [ALL] main: Camera 0 is device: /dev/video0 input -1
[0:motion] [NTC] [ALL] main: Stream port 8080
[0:motion] [NTC] [ALL] main: Waiting for threads to finish, pid: 804
[1:ml1] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:ml1] [ALR] [VID] mmalcam_start: MMAL Camera thread starting... for camera (vc.ril.camera) of 640 x 480 at 2 fps
[0:web_control] [NTC] [STR] http_bindsock: listening on port 8081
[0:web_control] [NTC] [STR] httpd_run: Started motion-httpd server on port 8081 (auth Disabled)
mmalipc: mmal_vc_init_fd: failed to initialise vchiq
mmal: mmal_vc_component_create: failed to initialise mmal ipc for 'vc.ril.camera' (7:EIO)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (7)
[1:ml1] [ERR] [VID] Failed to create MMAL camera component create_camera_component
[1:ml1] [ALR] [VID] MMAL Camera cleanup
[1:ml1] [WRN] [ALL] motion_init: Could not fetch initial image from camera Motion continues using width and height from config file(s)
[1:ml1] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:ml1] [NTC] [STR] http_bindsock: listening on any IPv4 address port 8080
[1:ml1] [NTC] [ALL] motion_init: Started motion-stream server on port 8080 (auth Disabled)
^C[0:web_control] [NTC] [STR] httpd_run: motion-httpd - Finishing
[0:web_control] [NTC] [STR] httpd_run: motion-httpd Closing
[0:web_control] [NTC] [STR] motion_web_control: motion-httpd thread exit
[1:ml1] [NTC] [ALL] motion_loop: End of event 1
[1:ml1] [NTC] [ALL] motion_loop: Thread exiting
[1:ml1] [NTC] [STR] stream_stop: Closing motion-stream listen socket & active motion-stream sockets
[1:ml1] [NTC] [STR] stream_stop: Closed motion-stream listen socket & active motion-stream sockets
[0:motion] [NTC] [ALL] main: Threads finished
[0:motion] [NTC] [ALL] main: Motion terminating

When I see what might be using the port 8080 or 8081 by using: ps aux | grep motion this is what it outputs:

admin      853  0.0  0.0   4372   532 pts/0    S+   13:23   0:00 grep --color=auto motion

I try and kill the process using:

sudo kill -9 853

but then it changes its PID everytime I try and kill it and use grep again.

The PiCamera Motion was working fine yesterday, only to find out this morning that it has stopped working. I'm really confused because once it was working yesterday I have not touched it since. I just want to send a test email or even view the stream that no longer works. Any fixes for this?

EDIT: This link worked! Live video streams and photos now work again!

  • 1
    The psoutput just shows the grepcommand. Apparently motion is not running so there is nothing to kill. The message seems to indicate that there is a problem accessing picamera. To debug I would first check if camera is visible with vcgencmd get_camera. If that's OK then try raspistill`.BTW: what model PI an which OS do you use? Please update your question with this information.
    – Dirk
    Sep 18, 2018 at 12:43
  • this appears to be a linux issue, not RPi issue .... there is some chatter on the web about failed to initialise vchiq
    – jsotola
    Sep 18, 2018 at 18:59
  • @Dirk Updated as requested
    – LtMuffin
    Sep 19, 2018 at 13:24

1 Answer 1


This link worked! Live video streams and photos now work again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.