0

I have a external HDD that is mounting automatically on my rpi. Thing is I don't use it anymore, it makes noise, and if I disconnect it, rpi won't boot, until I connect it.

I checked /etc/fstab, but I don't have the entry of my hdd.

Here is my fstab

pi@raspberrypi:~ $ cat /etc/fstab
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p6  /boot           vfat    defaults          0       2
/dev/mmcblk0p7  /               ext4    defaults,noatime  0       1
/dev/sdb1    /home/pi/Bureau/ssd    ext4    defaults,rw,user,exec,auto    0    0

/ is my microSD

/dev/sdb1 is a ssd drive, this one is used

Where should I look to disable automount ???

EDIT:

Output of mount:

pi@raspberrypi:/var/log $ mount
/dev/mmcblk0p7 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=470120k,nr_inodes=117530,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p6 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/sdb1 on /home/pi/Bureau/ssd type ext4 (rw,nosuid,nodev,relatime,data=ordered,user)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=94944k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/mmcblk0p5 on /media/pi/SETTINGS type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
/dev/sda1 on /media/pi/HDD type ntfs (ro,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0177,dmask=077,nls=utf8,errors=continue,mft_zone_multiplier=1,uhelper=udisks2)
18
  • how is it mounted - i.e. what is the output of mount – Jaromanda X Sep 21 '18 at 0:43
  • I don't know. how should I see it ? Any log file ? – Juliatzin del Toro Sep 21 '18 at 0:48
  • 1
    Looks like the lxde automount to me. Can be disabled in pcmanfm (File Manager). Menu Edit / Preferences – Dirk Sep 21 '18 at 6:46
  • 1
    @Milliways I used noobs to install raspbian June 2018 – Juliatzin del Toro Sep 21 '18 at 10:23
  • 2
    This may be a UUID issue. You've got a drive listed in fstab... but it's listed as sdb ... but there is no sdb because you've removed sda from the system. Try changing fstab to list sda for the drive that you wish to continue using... or even better convert the entry to UUID instead... you can find out the drive's UUID via lsblk -o NAME,UUID,MOUNTPOINT – RubberStamp Sep 21 '18 at 12:11
4

The problem you have is that the manually added /etc/fstab entry is enumerated by kernel device name rather than UUID. When a block device is detected by the kernel, it is assigned a name such as sda or sdb. The partitions are assigned sequential numbers such as sda1 sda2 or sdb1 sdb2. These are assigned according to when the kernel detects a device and not assigned per specific device. This means that if you have two external USB hard drives, they will be assigned different device names if attached in a different order. The first drive to be attached will always be sda. Because of this, the fstab entries may not match the actual devices that are expected to be mounted.

Your particular problem is that your fstab enumerates an sdb device, but there is no sdb device due to the removal of what used to be sda.

To avoid such confusion, it is advisable to identify mount devices by their UUID in /etc/fstab, especially for removable devices such as USB external hard drives.

As indicated in this Unix/Linux fstab Question/Answer you can easily obtain the UUID of any block device via the blkid command. And as indicated in the example, UUID entries in /etc/fstab should have the following format:

# UUID=Number                                     Mount Point      FS Type         Options         Dump Freq          FS Check
UUID=72bfc10d-73ec-4d9e-a54a-1cc507ee7ed2         /media/test        ext4            defaults          0                   0

So, you should either change the fstab entry so that the device listed matches the device name the kernel is assigning. Change /dev/sdb1 to /dev/sda1.

Or, for a much more robust solution, switch the fstab entry to UUID enumeration.

See man fstab or the online fstab manual page for more information on specific file system options and parameters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.